This is now in 40457 

#isSpecial is fixed, too.

This means that you can subclass AbstractInstanceVariableSlot and just override #read and #write:to: and it should work.

Hmm��� maybe IndexedSlot would be a better name���? I do not like AbstractSomethings. And it actually is not abstract,
it should work (just slower than InstanceVariableSlot)


I rename it but keep the AbstractInstanceVariableSlot subclass so it does not brake any code loading.
Any users should change AbstractInstanceVariableSlot to IndexedSlot, I will remove the class next week.

https://pharo.fogbugz.com/f/cases/14786/Slots-add-HiddenInstanceVariableSlot-and-rename-AbstractInstanceVariableSlot-to-IndexedSlot

Marcus