"DataSource" is responsible for providing visual elements that represent items in a data set.
I don't see how word "Store" fits here, because DataSource does not store anything.
DataSource is also not the best name since it is not a data source itself.
An object that is now called DataSource, basically just knows a single function that from mathematical point of view can be defined as follows:f: Object -> Morph . You see, it is a mapping, not a souse or store.Cheers,AlexOn 29 November 2016 at 09:44, Denis Kudriashov <dionisiydk@gmail.com> wrote:2016-11-29 9:35 GMT+01:00 Esteban Lorenzano <estebanlm@gmail.com>:yes, something like TableCellSource or TableCellProvider is more intention revealing.No, because is not *just* a cell provider.TableDataSource, TableStore, TableProvider, yes.I kind of like ���TableStore���.
And if we have TableMorph then this guy should be TableMorphStore IMO.