On 12 December 2017 at 20:03, Nicolas Cellier <nicolas.cellier.aka.nice@gmail.com> wrote:


2017-12-12 13:01 GMT+01:00 Henrik Sperre Johansen <henrik.s.johansen@veloxit.no>:
Ben Coman wrote
>
> But after pondering a while for a better name, I wonder what is wrong with
> the existing?
> Googling "define aggregate" provides...
>�� �� ��aggregate (noun) = a whole formed by combining several separate
> elements.
>�� �� ��aggregate (verb) = form or group into a class or cluster.
>
> The separate elements are runs defined by the block.
> The existing name seems quite precise to me.
>
> cheers -ben

When I read aggregateRuns:, I think the opposite; something combining
different runs into a single entity, not something that splits a single
collection into constituent runs...

okay. I can understand that perspective.��
��

Something like (split/collect)runsAccordingTo: sounds more descriptive to my
ears, at least.

Cheers,
Henry



I like groupBy: but in Squeak groupBy: produces a dictionary with unique keys ignoring the multiple sequences...
split already carries the meaning of preserving the sequences, but we have to tell to split at a change of value....
Run is also quite explicit...

groupByRuns: / splitRuns:

+1��
groupByRuns:�� ��is good.

cheers -ben