In my opinion, Java have the right name: an exception is something that not occurs every time by definition. In our case, a JobStartNotification is always thrown; which is the opposite of an exception


2013/7/11 Frank Shearar <frank.shearar@gmail.com>
On 11 July 2013 17:26, Camillo Bruni <camillobruni@gmail.com> wrote:
> On 2013-07-11, at 18:12, Sven Van Caekenberghe <sven@stfx.eu> wrote:
>> On 11 Jul 2013, at 18:05, Nicolas Cellier <nicolas.cellier.aka.nice@gmail.com> wrote:
>>
>>> Catching all/any Exception is generally considered a code smell
>>
>> In Pharo 3.0 AssertionFailure inherits from Error, which takes away my reason to catch Exception instead of Error.
>
> I always think we should add something like AbstractException which only contains the minimal interface.
> For me Exception has the wrong name (of course my bad Java experience doesn't help here...).

Just think of it this way: Java got the name wrong!

frank




--
Guillaume Larcheveque