Thank's Nicolas for answers.��
I have same vision.

2017-11-05 15:47 GMT+01:00 Nicolas Cellier <nicolas.cellier.aka.nice@gmail.com>:


SortByPropertyFunction -> shouldn���t be ���PropertySortFunction����� ? (coherent with the previous one)

+1 for PropertySortFunction, or maybe just PropertySorter
��
3) Function refers to SortFunction.
For this, I'm neutral, whether you call it Sorter or SortFunction I don't care.
SortFunction kind of implies these are stateless, so it's a rather good and accurate name.��
Maybe a Sorter could be more confusing, because a Sorter could be thought as having the sorted collection as instance variable (statefull).

Agree, I prefer SortFunction name instead of Sorter.
��

Nicolas


Esteban

>
> Stef
>