Hi,
An object that is called now "Animation" in Bloc is not necessarily bound to the visual element.
The correct name for the root class of "BlBaseAnimation" should be "BlPostAction" - a valuable that is guaranteed to be evaluated in the beginning of every frame before anything else. We have already a deferred action but they are only evaluated when there is enough time between frames.
"BlBaseAnimation" should be renamed to something line "BlElementAnimation" that is guaranteed to be bound to a visual element and stops itself if element is no more in the scene graph by checking that explicitly before doing every animation step.