[Pharo-users] pharo bash script with startup

Otto Behrens otto at finworks.biz
Wed Jun 27 02:30:17 EDT 2018


Hi,

I just installed pharo 6.1 using the .zip file (
http://files.pharo.org/platform/Pharo6.1-64-linux.zip) and battled to start
up pharo with arguments.

The issue is that the pharo bash script (in the extracted home dir) quotes
all arguments:

# execute
exec "$LINUX/pharo" \
        --plugins "$LINUX" \
        --encoding utf8 \
        -vm-display-X11 \
        "$image"

where

image = $*

The impact is that if I want to run a startup script, eg.

pharo my.image startup.st

pharo complains with "Could not open the Pharo image file: 'my.image
startup.st'

So I must run the executable directly?

If so, some questions about the options that the bash script passes in:
--plugins "$LINUX"    is this necessary? will the default not be enough?
--encoding utf8          the usage output says for example --textenc
default is "UTF-8". Is utf8 the same thing?
-vm-display-X11        I tried starting without this, and it worked. Do I
need to explicitly start with this?

Thanks
Otto
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20180627/24381842/attachment.html>


More information about the Pharo-users mailing list