[Pharo-users] Calypso - can we improve the bar of radio buttons?

Ben Coman btc at openinworld.com
Mon Jun 25 10:40:37 EDT 2018

On 25 June 2018 at 21:49, Tim Mackinnon <tim at testit.works> wrote:

> Hi - I don’t want to case a UI war, particularly as I was very impressed
> with Denis’ presentation about Calypso at the PharoDays conference last
> year.

I'm also very much enjoying Calypso.  Especially the multiple tabs for the
code pane
and being able to peak at the class definition half way through editing a

> Now that I’ve made a concerted effort to try and use Calypso, and in
> general like it,  I do however find that the bar of Radio Buttons above the
> tabs is a bit overwhelming and I’m wondering if there might be something we
> can do to help make it less so?
> I’m sure the problem is the age old observation that a checkbox or button
> that toggles between states is difficult to understand whether its on or
> off and what the alternate state is - so this is why we now have a row of 8
> radio buttons.
> But 8 is a lot of radio buttons… which  I find visually hard to parse and
> often find the order of the buttons the opposite to what I expect - eg.
> When I want to see class methods I keep pausing over that group to see
> which one to click (for some reason I keep thinking the class one should be
> before the instance one - not sure if anyone else notices this).
> I’m also not overly keen on the terminology of “side” (as in class side,
> vs inst. side) and equally I question abbreviations like: Hier. Inst. Refs.
> Can we not just get rid of that bar completely - and put little icon
> buttons next to the filter field for pkg/project and flat/hierarchy ?

It would be interesting to see an experiment that replaced that bar with
tabs above each pane:
Pane 1:  [Packages][Projects] tabs
Pane 2:  [Flat][Hierarchy] tabs
Pane 3:  [Instance][Class] tabs**
Pane 4:  [Method][Variables] tabs

If 3[Instance] > 4[Variables] would show

and 3[Class] > 4[Variables] would show

this could help familiarize newcomers with the scope of these terms.

cheers -ben

> OR  given the method pane is now a tree and it already has an entry
> “instance side” - why not just have entries for “instance methods” and
> “class methods” and just expand accordingly? We also now have a tab “Inst.
> side method” - why not 2 tabs “+instance method” and “+class method”. It
> breaks a bit with regular smalltalk browser conventions - but I think
> Calypso has already pushed the boat out on all this anyway in favour of
> improved navigation and ease of typing code.
> My understanding is that this is all pretty doable with the mechanism
> Denis has put in place. I’m tempted to have a look, but thought I’d see
> what that general feeling is here, as maybe I’m on my own here.
> Tim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20180625/abf29870/attachment.html>

More information about the Pharo-users mailing list