[Pharo-users] How do you clone Calypso to contribute to it?

Tim Mackinnon tim at testit.works
Fri Jun 22 12:36:51 EDT 2018

It seems that you have to use ssh for Calypso - not sure why, but at least I’ve got a clone now.

> On 22 Jun 2018, at 17:29, Tim Mackinnon <tim at testit.works> wrote:
> Ok - I give up - how do you add Calypso as a project to help contribute to it?
> I’ve downloaded the latest Pharo 7 image (1081), and I’ve tried to use the Github template to load my fork of Calypso. After several read herrings where I was getting a Github timeout (it turns out that Calypso isn’t in a src directory but in a root directory) I have gotten further, in that it loads the code, but at the end of the operation I always get “failed to connect to GitHub.com : Operation timed out”. It looks to have loaded all of the code and but then it looks to be doing a remote fetch to (pharo-ide (git://github.com/pharo-ide/Calypso.git)) - which isn’t the fork I’m cloning, and then it gets its knickers in a knot?
> I’m using https (which has worked so far for everything else) What is going on?
> Tim

More information about the Pharo-users mailing list