[Pharo-users] How to fix the Pharo launcher Windows installation! (WAS: Windows installation broken?)

PBKResearch peter at pbkresearch.co.uk
Mon Jun 18 16:15:10 EDT 2018


Vincent

 

Many thanks - at last a clear explanation of how to get it going. I tried
this with the Launcher I downloaded yesterday, and was able to launch the
template versions of Pharo 6.1 and Pharo 7. The only problem was that I am
not familiar with the Launcher interface, and I had to search around to open
the settings menu - but that was my stupidity. Plus I *hate* the dark theme
- but that's just my weird taste.

 

So going back to the original post in this thread, with this tweak the
Launcher is not broken as regards actually launching images. I have not
checked whether it is possible to uninstall it, as I found it was not
possible yesterday and Petr Fischer also had difficulty with. At present I
do not *want* to uninstall it, so that's OK.

 

All my tests on Windows 10 with all recent updates, on a 64-bit Intel Core
i3 processor.

 

Hope this helps

 

Peter Kenny

 

From: Pharo-users <pharo-users-bounces at lists.pharo.org> On Behalf Of
Vincent.Blondeau at lamresearch.com
Sent: 18 June 2018 20:28
To: pharo-users at lists.pharo.org
Subject: Re: [Pharo-users] How to fix the Pharo launcher Windows
installation! (WAS: Windows installation broken?)

 

Hi all,

 

Indeed, the Windows environment is not the one where Pharo is working the
best. Last week, I tried to install it on one of my coworker desktop and
there was some issues that was solvable with some workarounds, it is
temporary and the windows support will be improved soon: I'm currently
working on it, especially on making the Pharo launcher in a read only mode.
This way, no administrative privileges will be required to run the launcher.

 

In the meantime, to make the launcher working under Windows:

 

1.	Run with administrative privileges
2.	Uncheck: 

 

If you are in a mood to help and contribute to this project (I hope you
are!), please report the issues there:
<https://github.com/pharo-project/pharo-launcher/issues>
https://github.com/pharo-project/pharo-launcher/issues and feel free to
suggest some fixes to them :)

 

And please, keep this thread related to Pharo.

 

Thanks,

 

Vincent Blondeau 
Software Engineer, Software and Controls | Global Product Group 
Desk +1 510.572.7499


Lam Research Corporation
4650 Cushing Pkwy, Fremont, CA 94538 USA | www.lamresearch.com
Connect with Lam Research:
<https://www.facebook.com/LamResearchCorporation> Facebook |
<https://twitter.com/lamresearch> Twitter |
<https://www.linkedin.com/company/lam-research> LinkedIn

  _____  

                 

NOTICE: This e-mail transmission may contain confidential information. If
you are not the intended recipient, or a person responsible for delivering
it to the intended recipient, you are hereby notified that any disclosure,
copying, distribution or use of any of the information contained in or
attached to this message is STRICTLY PROHIBITED. If you have received this
transmission in error, please immediately notify the sender and destroy the
original transmission and its attachments without reading them or saving
them to disk. Thank you.

 

 

 

-----Original Message-----
From: Pharo-users [ <mailto:pharo-users-bounces at lists.pharo.org>
mailto:pharo-users-bounces at lists.pharo.org] On Behalf Of horrido
Sent: Sunday, June 17, 2018 15:04
To:  <mailto:pharo-users at lists.pharo.org> pharo-users at lists.pharo.org
Subject: Re: [Pharo-users] Windows installation broken?

 

This is what concerns me. I don't care that there are workarounds
(undocumented or hard to find).

 

I care that Windows is a most popular development platform. I care that
newcomers to Pharo easily find what they need to get started. I care about
Pharo's reputation.

 

The last thing Pharo needs is a black eye.

 

 

Travis Ayres wrote

> I wonder how many people tried Pharo, thought "Oh this is totally broken"

> and are never going to give it a second (or third) chance.

> 

> On Sun, Jun 17, 2018 at 11:26 AM,

 

> phil@

 

>  <

 

> phil@

 

> >

> wrote:

> 

>> The current website shows the wrong link, the installer for the 

>> bleeding edge is the wrong one in files.

>> The situation on the Windows front is very very bad and not really 

>> improving.

>> 

>> That being said, the installer on the CI is the right one and works.

>> 

>> so, steal the installer from here: 

>>  <https://urldefense.proofpoint.com/v2/url?u=https-3A__ci.inria.fr_phar>
https://urldefense.proofpoint.com/v2/url?u=https-3A__ci.inria.fr_phar

>> o-2Dci-2D&d=DwICAg&c=RWI7EqL8K9lqtga8KxgfzvOYoob76EZWE0yAO85PVMQ&r=kI

>> ZIYXBAA3fhM7P5HOuTC5w6mnEApTfXPTq3lR34ZiY&m=klRHeEtFlmi7VP-TR5D2bSZ_E

>> UF1hAdJcuTH4GnReBY&s=xfU91HKFoB5JIZXWRUqBvOkomomuAqWw_gQvBmGRwiw&e=

>> jenkins2/job/PharoLauncher

>> 

>> This is the one you want:

>> 

>>  <https://urldefense.proofpoint.com/v2/url?u=https-3A__ci.inria.fr_phar>
https://urldefense.proofpoint.com/v2/url?u=https-3A__ci.inria.fr_phar

>> o-2Dci-2Djenkins2_job_PharoLauncher_&d=DwICAg&c=RWI7EqL8K9lqtga8Kxgfz

>> vOYoob76EZWE0yAO85PVMQ&r=kIZIYXBAA3fhM7P5HOuTC5w6mnEApTfXPTq3lR34ZiY&

>> m=klRHeEtFlmi7VP-TR5D2bSZ_EUF1hAdJcuTH4GnReBY&s=TsRgHOYVLDp0q9g8BzEb8

>> s8yLy_v32DEMOxtvIcvTOg&e=

>> 

>> For having the latest lastet everything, go to the launcher settings, 

>> get into the devmode and open monticello and load the latest packages.

>> 

>> Phil

 

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20180618/6198a61d/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: image001.png
Type: image/png
Size: 3519 bytes
Desc: not available
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20180618/6198a61d/attachment-0001.png>


More information about the Pharo-users mailing list