[Pharo-users] Windows installation broken?

Sven Van Caekenberghe sven at stfx.eu
Mon Jun 18 10:02:17 EDT 2018



> On 18 Jun 2018, at 15:39, Herbert Vojčík <herby at mailbox.sk> wrote:
> 
> 
> 
> horrido wrote on 18. 6. 2018 0:04:
>> This is what concerns me. I don't care that there are workarounds
>> (undocumented or hard to find).
>> I care that Windows is a most popular development platform. I care that
>> newcomers to Pharo easily find what they need to get started. I care about
>> Pharo's reputation.
>> The last thing Pharo needs is a black eye.
> 
> Do you have enough balls to call out Steph for his obviously wrong decision to push Launcher down the users' throats and make him revert to working installers / zips? Cause AFAICT there's the bottleneck atm.

The problem is the lack of enough Windows users and especially developers who can fix Windows problems.

The 'first contact for people who don't know Pharo' on Windows is really hard for an IDE.

And although I am not daily using the Launcher myself, I too believe it is a really good tool for many users. It just needs fixing and maintenance, like everything out there that wants to be successful in our ever changing world.

> Herby
> 
>> Travis Ayres wrote
>>> I wonder how many people tried Pharo, thought "Oh this is totally broken"
>>> and are never going to give it a second (or third) chance.
>>> 
>>> On Sun, Jun 17, 2018 at 11:26 AM,
>>> phil@
>>>  <
>>> phil@
>>> >
>>> wrote:
>>> 
>>>> The current website shows the wrong link, the installer for the bleeding
>>>> edge is the wrong one in files.
>>>> The situation on the Windows front is very very bad and not really
>>>> improving.
>>>> 
>>>> That being said, the installer on the CI is the right one and works.
>>>> 
>>>> so, steal the installer from here: https://ci.inria.fr/pharo-ci-
>>>> jenkins2/job/PharoLauncher
>>>> 
>>>> This is the one you want:
>>>> 
>>>> https://ci.inria.fr/pharo-ci-jenkins2/job/PharoLauncher/
>>>> 
>>>> For having the latest lastet everything, go to the launcher settings, get
>>>> into the devmode and open monticello and load the latest packages.
>>>> 
>>>> Phil
>> --
>> Sent from: http://forum.world.st/Pharo-Smalltalk-Users-f1310670.html
> 




More information about the Pharo-users mailing list