[Pharo-users] more on "can't get keyboard shortcuts to work on Mac"

Gregg Williams gregg13 at innerpaths.net
Mon Jun 4 23:50:01 EDT 2018


Tim and Ben,

Thanks for your help. Sorry for not being clear. When I said "I just can't get keyboard shortcuts to work on Mac," what I should have said is "I just can't get Pharo-specific shortcuts to work on the Macintosh implementation of Pharo" (6.1 is what I'm using BTW).

Maybe I should have said "keymap shortcuts"? I'm talking about things like Meta+Shift+f for 'find class', and Meta+x, Meta+m for 'remove method'.

I've looked for what the definition of Meta is for Mac OS. All I can find is meta-click is Shift+Option+click, but that doesn't seem to work. Option + <many keys> gives "special characters" like ∂, ß, and œ.

I hope that now you can simply say, "Oh, of course, what you need to do is…". Thanks!


> I just can't get keyboard shortcuts to work on Mac. I?ve tried a lot of stuff, more than I can list here. Here are some things I?ve tried:
> 
> * searching the Pharo by Example book
> * turning off all Mac keyboard-macro programs
> * switching from extended to standard US keyboard
> * looking at options in System Preferences > Keyboard
> 
> 
> If you?re on the Mac, do you have this problem? If so, what?s your solution? Thanks!
> 




More information about the Pharo-users mailing list