[Pharo-users] can't get keyboard shortcuts to work on Mac

Ben Coman btc at openinworld.com
Sat Jun 2 21:32:25 EDT 2018


On 3 June 2018 at 02:11, Gregg Williams <gregg13 at innerpaths.net> wrote:

> I just can't get keyboard shortcuts to work on Mac. I’ve tried a lot of
> stuff, more than I can list here. Here are some things I’ve tried:
>
> * searching the Pharo by Example book
> * turning off all Mac keyboard-macro programs
> * switching from extended to standard US keyboard
> * looking at options in System Preferences > Keyboard
>
> I found some “unmapping option-key-plus-letter” solutions at
> https://stackoverflow.com/questions/11876485/how-to-
> disable-typing-special-characters-when-pressing-
> option-key-in-mac-os-x?utm_medium=organic&utm_source=
> google_rich_qa&utm_campaign=google_rich_qa
> …but yikes, that seems extreme!
>
> If you’re on the Mac, do you have this problem? If so, what’s your
> solution? Thanks!
>

I've not heard of this happening before.

Checking a specific example...
if you are looking at a method with text selected using the mouse,
you are unable to use CMD-X to cut it to the clipboard?

cheers -ben
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20180603/543e7973/attachment.html>


More information about the Pharo-users mailing list