[Pharo-users] Morphic is super slow

Marcus Denker marcus.denker at inria.fr
Sat Jan 16 08:00:29 EST 2016


and this is all fixed by https://pharo.fogbugz.com/f/cases/17201/Marking-Diffs-broken-in-Pharo5


> On 16 Jan 2016, at 13:55, Henrik Nergaard <henrik.nergaard at uia.no> wrote:
> 
> Both the syntax highlighting and critics run their own background process to do work.
> The general Morphic UI runs at priority 40, critics at 39 and 30.
> This means that highlighting will not be computed before the critics have finished evaluating, and if there is too much work in the UI thread both of these will take forever.
>  
> Best regards,
> Henrik
>  
>  
> From: Pharo-users [mailto:pharo-users-bounces at lists.pharo.org <mailto:pharo-users-bounces at lists.pharo.org>] On Behalf Of Dimitris Chloupis
> Sent: Saturday, January 16, 2016 12:00 PM
> To: Any question about pharo is welcome <pharo-users at lists.pharo.org <mailto:pharo-users at lists.pharo.org>>
> Subject: Re: [Pharo-users] Morphic is super slow
>  
> syntax highlighting does not work, critics its keep looping forever with "Updating critics..." message. I have to minimise and restore the nautlius window to get back syntax highlighting for one method then the next method i have to do the same. 
> 
> Big Nope....
> 
> Back I go to Pharo 4. Pharo 5 simply does not like me :D 
>  
> On Sat, Jan 16, 2016 at 12:54 PM Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
>  
> ok if I open a nautilus window and then I save the image , it does not create this error
> 
> o_O
> 
> crazy stuff 
> 
> :D
>  
> On Sat, Jan 16, 2016 at 12:51 PM Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
> <image001.png>
> 
> yes even with stable VM is a mess, new problem 
> 
> I got pharo with this
> 
> wget -O- get.pharo.org/alpha+vm <http://get.pharo.org/alpha+vm> | bash
> 
> downloads fines, loads my libraries fine with my startup script as soon as i try to save the image the above happens
> 
> 
> 
>  
> On Sat, Jan 16, 2016 at 12:43 PM Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
> Esteban I also get doSemantics: errors , I have been getting way way back before Spur while trying to use shortcuts. It was messing also with the rendering of the method list in Nautilus when there were too many methods, it turned to a red box of death. So I am not convinced my problem are just VM related but you can correct me if I am wrong. 
>  
> On Sat, Jan 16, 2016 at 12:41 PM Esteban Lorenzano <estebanlm at gmail.com <mailto:estebanlm at gmail.com>> wrote:
> On 16 Jan 2016, at 11:27, Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
>  
> yes thanks Esteban I am back to Pharo 4 and I am fine :) 
>  
> you do not need to go back to Pharo 4… just downloading stable VM is enough :)
> (and I need people helping me to find the bugs on Pharo 5, spur, FFI, etc. *before* release :P)
>  
> cheers,
> Esteban
> 
> 
>  
> will stick with it, till the release of Pharo 5. 
>  
> On Sat, Jan 16, 2016 at 12:25 PM Esteban Lorenzano <estebanlm at gmail.com <mailto:estebanlm at gmail.com>> wrote:
> On 16 Jan 2016, at 01:01, Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
>  
> <Screen Shot 2016-01-16 at 00.38.10.png>
> 
> and by the way menus on latest pharo 5 are broken 
>  
> not the menus
> there is a problem with WideString and string primitives in latest spur vm. 
> in the mean time you can download stable instead latest and you will be ok.
>  
> Esteban
> 
> 
>  
> 
> On Sat, Jan 16, 2016 at 1:29 AM Nicolai Hess <nicolaihess at gmail.com <mailto:nicolaihess at gmail.com>> wrote:
> 2016-01-16 0:11 GMT+01:00 Nicolai Hess <nicolaihess at gmail.com <mailto:nicolaihess at gmail.com>>:
>  
>  
> 2016-01-16 0:06 GMT+01:00 Sven Van Caekenberghe <sven at stfx.eu <mailto:sven at stfx.eu>>:
> 
> > On 15 Jan 2016, at 23:30, Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
> >
> > taskbar was the problem, damn pharo gui is a huge pain in the hat.
> 
> How so ?
>  
> I would like to now that too.
> 
> Btw, this is interesting too:
> 
> WorldState debugShowDamage:true.
> 
> And look all the flashing in a nautilus and or playground window.
>  
> Hm, I think this was my fault. The fix for
> 17201 <https://pharo.fogbugz.com/f/cases/17201/Marking-Diffs-broken-in-Pharo5> Marking Diffs broken in Pharo5
> wasn't good.
> 
> 
>  
>  
> 
> > On Fri, Jan 15, 2016 at 11:32 PM Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
> > ITs not the step, I removed the step as I said in my first post. Still 30% cpu consumption
> >
> > The images are PNGs and RGBA , 8bit
> >
> >
> > On Fri, Jan 15, 2016 at 10:54 PM Hilaire <hilaire at drgeo.eu <mailto:hilaire at drgeo.eu>> wrote:
> > It depends on what you are doing in a step, but 1s step should not hurt.
> > May be the problem is somewhere else.
> > With DrGeo, I noted Athens is faster to BitBlt with bitmap operations
> > (in my case, only scaling and displaying a From in a DrGeo canvas).
> > Also, do your bitmaps come with 32 bits depth?
> >
> > --
> > Dr. Geo
> > http://drgeo.eu <http://drgeo.eu/>
> >
> >
> >
> 
> 
>  
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20160116/2439eaac/attachment.html>


More information about the Pharo-users mailing list