[Pharo-users] Morphic is super slow

Esteban Lorenzano estebanlm at gmail.com
Sat Jan 16 05:40:23 EST 2016


> On 16 Jan 2016, at 11:27, Dimitris Chloupis <kilon.alios at gmail.com> wrote:
> 
> yes thanks Esteban I am back to Pharo 4 and I am fine :) 

you do not need to go back to Pharo 4… just downloading stable VM is enough :)
(and I need people helping me to find the bugs on Pharo 5, spur, FFI, etc. *before* release :P)

cheers,
Esteban

> 
> will stick with it, till the release of Pharo 5. 
> 
> On Sat, Jan 16, 2016 at 12:25 PM Esteban Lorenzano <estebanlm at gmail.com <mailto:estebanlm at gmail.com>> wrote:
>> On 16 Jan 2016, at 01:01, Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
>> 
>> <Screen Shot 2016-01-16 at 00.38.10.png>
>> 
>> and by the way menus on latest pharo 5 are broken 
> 
> not the menus
> there is a problem with WideString and string primitives in latest spur vm. 
> in the mean time you can download stable instead latest and you will be ok.
> 
> Esteban
> 
>> 
>> 
>> On Sat, Jan 16, 2016 at 1:29 AM Nicolai Hess <nicolaihess at gmail.com <mailto:nicolaihess at gmail.com>> wrote:
>> 2016-01-16 0:11 GMT+01:00 Nicolai Hess <nicolaihess at gmail.com <mailto:nicolaihess at gmail.com>>:
>> 
>> 
>> 2016-01-16 0:06 GMT+01:00 Sven Van Caekenberghe <sven at stfx.eu <mailto:sven at stfx.eu>>:
>> 
>> > On 15 Jan 2016, at 23:30, Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
>> >
>> > taskbar was the problem, damn pharo gui is a huge pain in the hat.
>> 
>> How so ?
>> 
>> I would like to now that too.
>> 
>> Btw, this is interesting too:
>> 
>> WorldState debugShowDamage:true.
>> 
>> And look all the flashing in a nautilus and or playground window.
>> 
>> Hm, I think this was my fault. The fix for
>> 17201 <https://pharo.fogbugz.com/f/cases/17201/Marking-Diffs-broken-in-Pharo5> Marking Diffs broken in Pharo5
>> wasn't good.
>> 
>> 
>>  
>>  
>> 
>> > On Fri, Jan 15, 2016 at 11:32 PM Dimitris Chloupis <kilon.alios at gmail.com <mailto:kilon.alios at gmail.com>> wrote:
>> > ITs not the step, I removed the step as I said in my first post. Still 30% cpu consumption
>> >
>> > The images are PNGs and RGBA , 8bit
>> >
>> >
>> > On Fri, Jan 15, 2016 at 10:54 PM Hilaire <hilaire at drgeo.eu <mailto:hilaire at drgeo.eu>> wrote:
>> > It depends on what you are doing in a step, but 1s step should not hurt.
>> > May be the problem is somewhere else.
>> > With DrGeo, I noted Athens is faster to BitBlt with bitmap operations
>> > (in my case, only scaling and displaying a From in a DrGeo canvas).
>> > Also, do your bitmaps come with 32 bits depth?
>> >
>> > --
>> > Dr. Geo
>> > http://drgeo.eu <http://drgeo.eu/>
>> >
>> >
>> >
>> 
>> 
>> 
>>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20160116/860002c8/attachment.html>


More information about the Pharo-users mailing list