[Pharo-users] Attempting Pharo Book #3 WebApp Example on a 64-bit iMac

Sven Van Caekenberghe sven at stfx.eu
Thu Oct 29 02:47:48 EDT 2015


Hi Bruce,

> On 29 Oct 2015, at 00:22, Bruce Prior <b.prior at ieee.org> wrote:
> 
> I worked my way through Sven van Caekenberghe's excellent tutorial on building and deploying a web app on Digital Ocean's cloud server. All went well at first, even though Digital Ocean didn't offer a Mac option (I picked Ubuntu Linux).
> 
> I skipped the Tests and Configuration parts of Sven's tutorial in order to get to the deployment part faster. I thought I could come back to those parts.
> 
> I was able to get SSH command line access to the new server and loaded Pharo using curl (See Sven's Section 12.3). But when I went to test the setup using
> # ./pharo Pharo.image printVersion 
> I got an error saying pharo not found even though it was there in the pharo-vm directory.
> 
> I suspect that my attempt to do all this on an Apple iMac is the problem. Has anyone else tried using a Mac with Digital Ocean? 

Pharo runs cross platform, Mac OS X is certainly no problem since that is what most people are using. 

Now, you are deploying on Ubuntu Linux, which is essentially independent from where you are developing.

I am not sure what went wrong, but did you select a 32-bit Ubuntu variant ? What does 'uname -a' say ? Can you copy/paste the literal error ? 64-bit does also work, but you need to do some extra stuff, for a 1st tutorial I would skip that part.

HTH,

Sven





More information about the Pharo-users mailing list