[Pharo-users] VM crash on Ubuntu 14.04

Nicolai Hess nicolaihess at gmail.com
Tue Oct 27 18:09:47 EDT 2015


2015-10-26 15:03 GMT+01:00 Johan Fabry <jfabry at dcc.uchile.cl>:

> Hi Nicolai,
>
> thanks for following up on this.
>
> I am in the process of determining what causes the crash. I fear that to
> reproduce the problem you will need to have ROS installed, I have not yet
> been able to reproduce it without ROS running. I do not want to inflict the
> installation of ROS on you without being 100% sure.
>
> I am using Roassal because this is for Live Robot Programming (
> http://pleiad.cl/LRP) which uses a dynamic visualization of the running
> code. To reproduce the bug (until now) I need to develop code in LRP when
> using ROS, and then it happens randomly. I realize that this is too much to
> ask for an outsider to reproduce the bug (I did not expect anybody to
> download and install PhaROS to try to reproduce, thanks for that!!).
>
> Can you inform me how I can get you more useful debug info to you? I will
> keep trying to find minimal steps to reproduce in the mean time.
>

No, the best we can hope for is a crash when it is running from debugger,
you can start the vm with a debugger or
attach the debugger to a running process. If we  are lucky, the debugger
will show a stacktrace.


>
> On Oct 24, 2015, at 19:45, Nicolai Hess <nicolaihess at gmail.com> wrote:
>
> Can you provide the image file.
> What exactly runs in the image (does it depend on ROS or
> does it crash even without it). For what do you
> use Roassal in this environment.
> Can you reproduce the crash with a clean image (and maybe loading
> some package - without all of the ROS-stuff?
> (I just followed the installation guide for PhaROS, but I have no idea
> how to go from here to do anything to reproduce the crash).
>
>
>
> 2015-10-24 21:32 GMT+02:00 Johan Fabry <jfabry at dcc.uchile.cl>:
>
>>
>> Ben, thanks for replying but since no VM guys are following up on this,
>> apparently, it does not make much sense for me to go this way.
>>
>> Guys, am I to assume there is not help for me on this topic?
>>
>> > On Oct 23, 2015, at 11:03, Ben Coman <btc at openInWorld.com> wrote:
>> >
>> > On Thu, Oct 22, 2015 at 2:25 AM, Johan Fabry <jfabry at dcc.uchile.cl>
>> wrote:
>> >> Hi all,
>> >>
>> >> I am having some unpleasant experiences on Ubuntu 14.04 (experimenting
>> with Live Robot Programming on PhaROS). The VM crashes after a random
>> amount of time (< 25 minutes), with no clear sequence of steps on how to
>> reproduce the crash. I am using Pharo 4 (Pharo 40622 as installed by
>> PhaROS) + Roassal which required an install of libcairo2:i386 . VM version
>> details below.
>> >>
>> >> There is no printout on stdout, and the debug.log does not contain
>> recent entries (timestamp is always some minutes before the actual crash
>> happens).
>> >>
>> >> Is this a known problem? If so, how can I fix it, and if not how can I
>> provide more debugging info?
>> >>
>> >> Thanks in advance!
>> >
>> > I'm not much help since I haven't done these myself, but just some
>> > ideas (maybe someone can add more details)
>> > * compile and run a debug vm
>> > * trace all function calls, http://tinyurl.com/gdb-trace-all
>> >
>>
>>
>>
>> ---> Save our in-boxes! http://emailcharter.org <---
>>
>> Johan Fabry   -   http://pleiad.cl/~jfabry
>> PLEIAD and RyCh labs  -  Computer Science Department (DCC)  -  University
>> of Chile
>>
>>
>>
>
>
>
> ---> Save our in-boxes! http://emailcharter.org <---
>
> Johan Fabry   -   http://pleiad.cl/~jfabry
> PLEIAD and RyCh labs  -  Computer Science Department (DCC)  -  University
> of Chile
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20151027/cbd688ef/attachment.html>


More information about the Pharo-users mailing list