[Pharo-users] Problem to connect Seaside and Pharo

Justine STIENNE justine.stienne at gmail.com
Mon Oct 26 11:38:20 EDT 2015


Thank you for your help. You're right, I'm mixing instance and class side,
I will revise it.
I'm following the standard Pharo book.

Justine

2015-10-26 9:31 GMT+01:00 Sven Van Caekenberghe <sven at stfx.eu>:

>
> > On 26 Oct 2015, at 09:09, Justine STIENNE <justine.stienne at gmail.com>
> wrote:
> >
> > Of course. Sorry to bother you but I'm a beginner.
>
> OK, no problem.
>
> You are mixing instance and class side. All your methods except
> #renderContentOn: should be on the class side. There should also be no
> super initialise on the class side.
>
> What book/tutorial are you following ?
>
> Standard Pharo books are at http://books.pharo.org
>
> You should make sure that you read and experiment with the first one.
>
> There is also the Seaside book.
>
> The learning curve in the beginning can be quite steep, depending on your
> background, nothing to worry about.
>
> > 2015-10-26 9:01 GMT+01:00 Sven Van Caekenberghe <sven at stfx.eu>:
> > Could you do a File Out of your WAHelloWorld class code and show us ?
> >
> > > On 26 Oct 2015, at 08:58, Justine STIENNE <justine.stienne at gmail.com>
> wrote:
> > >
> > > I have just done it. And now, on 'http://localhost:8080/config/hello'
> , I can choose 'a WAHelloWorld', but not 'WAHelloWorld'.
> > > When I go to 'http://localhost:8080/hello', I have :
> > > MessageNotUnderstood: WAHelloWorld>>new
> > >
> > > Your request could not be completed. An exception occurred.
> > >
> > >
> > >
> > > Thanks in advance,
> > >
> > > Justine
> > >
> > >
> > >
> > > 2015-10-25 20:03 GMT+01:00 Sven Van Caekenberghe <sven at stfx.eu>:
> > > You have to do (Do it) the #initialize as well, like
> > >
> > > MyExample initialize.
> > >
> > > Or browse the method and highlight the body and evaluate it (Do it).
> > >
> > > > On 25 Oct 2015, at 20:00, Justine STIENNE <justine.stienne at gmail.com>
> wrote:
> > > >
> > > > Oh sorry it was not for this conversation. I tried to do what you
> said, but it doesn't work again.
> > > >
> > > > Justine
> > > >
> > > > 2015-10-25 19:55 GMT+01:00 Justine STIENNE <
> justine.stienne at gmail.com>:
> > > > The installation is ok ! :-) But i cant open the file bak that you
> give me :-/
> > > >
> > > > 2015-10-25 18:53 GMT+01:00 Sven Van Caekenberghe <sven at stfx.eu>:
> > > > Hi,
> > > >
> > > > > On 25 Oct 2015, at 18:46, Justine STIENNE <
> justine.stienne at gmail.com> wrote:
> > > > >
> > > > > Hello,
> > > > >
> > > > > I have a problem to connect Seaside and Pharo. I explain :
> > > > >
> > > > > ZnZincServerAdaptor is running. When I open localhost:8080, it
> works. When I want to configure a new entry, I can't find the class that I
> made on Pharo. I have put the method canBeRoot with true as return value on
> a class but I can't find it. Can you help me ?
> > > > >
> > > > > Thanks in advance,
> > > > > Justine
> > > >
> > > > #canBeRoot is just an indication, it has no real effect on its own.
> > > >
> > > > Traditionally, WAComponent subclasses register themselves explicitly
> using #initialize on the class side, like this:
> > > >
> > > > initialize
> > > >   WAAdmin register: self asApplicationAt: self handlerName
> > > >
> > > > Look for the senders of #register:asApplicationAt: to see what I
> mean.
> > > >
> > > > Sven
> > > >
> > > >
> > > >
> > >
> > >
> > >
> >
> >
> >
> > <WAHelloWorld.st>
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20151026/67a76552/attachment.html>


More information about the Pharo-users mailing list