[Pharo-users] What's wrong whith this code?

PBK Research peter at pbkresearch.co.uk
Wed Mar 19 06:25:44 EDT 2014


Well I did some experiments, and I seem to have a solution. In the method
Collection>>do:displayingProgress:every:, you will find (three lines from
the end) the line:
                                         ifFalse: [ProgressNotification
signal: '' extra: (oldLabel := newLabel)].

If you replace that with:

                                         ifFalse: [bar label: (oldLabel :=
newLabel)].

you will find that the examples of changing labels will work. I haven't
tested this as thoroughly as I should, so there may be other consequences,
but clearly this is where the problem lies. 

 

Peter Kenny


  _____  

From: Pharo-users [mailto:pharo-users-bounces at lists.pharo.org] On Behalf Of
PBK Research
Sent: 19 March 2014 09:09
To: nicolaihess at web.de; 'Any question about pharo is welcome'
Subject: Re: [Pharo-users] What's wrong whith this code?


Note however that the first example used in the method comment, which
displays a static label, does work. There is something wrong in the method
of computing the changing label in the second example. I can't follow the
code here, so I can't see the error, but it should be clear where to look.
 
Peter Kenny

  _____  

From: Pharo-users [mailto:pharo-users-bounces at lists.pharo.org] On Behalf Of
Nicolai Hess
Sent: 19 March 2014 08:56
To: Any question about pharo is welcome
Subject: Re: [Pharo-users] What's wrong whith this code?


2014-03-19 8:17 GMT+01:00 Friedrich Dominicus
<frido at q-software-solutions.de>:


Bernat Romagosa <tibabenfortlapalanca at gmail.com> writes:

> ouch, I added a . in the middle, sorry!
>
> elements := #('eins' 'zwei' 'drei' 'vier').
> elements
> do: [ :element | (Delay forSeconds: 2) wait ]
> displayingProgress: [ :element | 'Working on', element asString ].
>
> 2014-03-18 9:55 GMT+01:00 Bernat Romagosa
> <tibabenfortlapalanca at gmail.com>:
>
>     Without having tried it, I think you're missing a #wait message in
>     there:
>
>
>
>     elements := #('eins' 'zwei' 'drei' 'vier').
>     elements do: [ :element | (Delay forSeconds: 2) wait ].
>
>     displayingProgress: [ :element | 'Working on', element asString ].

Sorry even with that I do not see the 'Working on ' message.
It's just a progress bar with nothing else. No "Working on" anywhere.

Regards
Friedrich





It doesn't work anymore. (This worked in Pharo 1.4)
In the comment of Collection>>do:displayingProgress:
is a example, that doesn't work:
Smalltalk allClasses 
            do:[:aClass| (Delay forMilliseconds: 1) wait]
            displayingProgress:[:aClass| 'Processing ', aClass name].


This should show the class names but it shows
only a single progressbar.






-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-users_lists.pharo.org/attachments/20140319/bc409939/attachment.html>


More information about the Pharo-users mailing list