[Pharo-dev] Proposal to remove [Stream|Collection]>>#write:

ducasse stepharo at netcourrier.com
Fri Feb 22 09:43:12 EST 2019


+ 1 
:)
But I’m an easy person when it is about cleaning. 

> On 22 Feb 2019, at 15:39, Sven Van Caekenberghe <sven at stfx.eu> wrote:
> 
> Hi,
> 
> Did you know that both Stream and Collection respond to #write: (as an alias to #<< and #add: respectively) ? I sure did not (and I did quite a bit of stream hacking).
> 
> This selector is not used for these 2 receiver types in the standard image (except for one unit test), I never saw it being used in actual code.
> 
> These are just aliases that add nothing but cognitive load.
> 
> They make the API's of two important hierarchies (and especially the interface for non-inheriting classes) heavier than needed for no functional benefit.
> 
> So I propose to remove [Stream|Collection]>>#write:
> 
> What say thou ?
> 
> Sven
> 
> 





More information about the Pharo-dev mailing list