[Pharo-dev] Question on KmGlobalDispatcher
btc at openinworld.com
Wed Feb 20 10:58:58 EST 2019
I invite you to consider this an opportunity to submit a PR to fix it.
I'm happy to walk you though the process if you ping me on Discord chat.
I remember it felt cool to have my first code integrated.
Pharo is yours.
On Wed, 20 Feb 2019 at 02:16, ducasse <stepharo at netcourrier.com> wrote:
> Hello David
> Indeed this is a good catch.
> Can you open a bug entry on github?
> Else I will do it but this is cool to get involved that way
> On 19 Feb 2019, at 17:37, David Richards <david.i.richards.iii at gmail.com>
> Why does the class name KmGlobalDispatcher have a small 'm'?
> Should it be more consistently named KMGlobalDispatcher, as all other
> classes in package: 'Keymapping-Core'?
> Object subclass: #KmGlobalDispatcher
> instanceVariableNames: 'dispatcher'
> classVariableNames: ''
> package: 'Keymapping-Core'
> Just curious why this name seems inconsistent. I don't recall seeing an
> inconsistency with class name prefixes in any other package group. Is this
> just a mistake, or rather an opportunity to learn something interesting
> about how classes should be named in Pharo? As a beginner, I'm not sure
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Pharo-dev