[Pharo-dev] ConfigurationOfGrease for Pharo8

ducasse stepharo at netcourrier.com
Sun Feb 3 15:55:42 EST 2019


HI alistair

you should use the latest pillar. Was dev-7 and now it is 70 
because this is around six months that we removed the dependency to grease. 

Now if you need help to migrate a book/doc from pillar 6 to 7 let me know I can help.
I migrated many of the books to validate Pillar 70. 

It is three weeks that we do not find the time to officially release it but it is super stable.

Stef

> On 3 Feb 2019, at 21:48, Alistair Grant <akgrant0710 at gmail.com> wrote:
> 
> Hi Cyril & Sven,
> 
> I was loading an old version of Pillar, so that solves the Grease version info.
> 
> Thanks again,
> Alistair
> 
> 
> On Sun, 3 Feb 2019 at 19:25, Alistair Grant <akgrant0710 at gmail.com> wrote:
>> 
>> Hi Cyril & Sven,
>> 
>> Thanks for the pointer.  I'll have to figure out why it is being
>> loaded from smalltalkhub - maybe Pillar?  Anyway, I'll have a look.
>> 
>> Thanks again,
>> Alistair
>> 
>> On Sun, 3 Feb 2019 at 19:22, Cyril Ferlicot <cyril.ferlicot at gmail.com> wrote:
>>> 
>>> 
>>> 
>>> On Sun 3 Feb 2019 at 19:20, Alistair Grant <akgrant0710 at gmail.com> wrote:
>>>> 
>>>> Hi All,
>>>> 
>>>> It looks like Grease is still hosted on smalltalkhub - if not, please
>>>> let me know where.
>>> 
>>> 
>>> Hi,
>>> 
>>> Here:
>>> 
>>> https://github.com/SeasideSt/Grease
>>> 
>>> :)
>>> 
>>>> 
>>>> Are there any objections to me updating
>>>> ConfigurationOfGrease>>release1: to load on Pharo8?
>>>> 
>>>> The updated method is (apologies for loss of formatting):
>>>> 
>>>> release1: aSpec
>>>> <symbolicVersion:#'release1'>
>>>> aSpec for: #'pharo3.x' version: #'release1.3'.
>>>> aSpec for: #'pharo4.x' version: #'release1.3'.
>>>> aSpec for: #'pharo5.x' version: #'release1.3'.
>>>> aSpec for: #'pharo6.x' version: #'release1.3'.
>>>> aSpec for: #'pharo7.x' version: #'release1.3'.
>>>> aSpec for: #'pharo8.x' version: #'release1.3'.
>>>> aSpec for: #'squeak5.x' version: #'release1.3'.
>>>> aSpec for: #'gs3.x' version: #'release1.3'.
>>>> aSpec for: #'pharo1.x' version: #'release1.2'.
>>>> aSpec for: #'pharo2.x' version: #'release1.2'.
>>>> aSpec for: #'squeak4.x' version: #'release1.2'.
>>>> aSpec for: #'gs2.x' version: #'release1.2'
>>>> 
>>>> The change is the addition of the #'pharo8.x' line.
>>>> 
>>>> Thanks,
>>>> Alistair
>>>> 
>>> --
>>> Cyril Ferlicot
>>> https://ferlicot.fr
> 





More information about the Pharo-dev mailing list