[Pharo-dev] Lowering the pain of newbies

Dimitris Chloupis kilon.alios at gmail.com
Mon Aug 21 08:42:01 EDT 2017


its inconsistent to start using (set) in front of the name of methods and
unnecessary

className:

makes more sense to me

Another way to do this instead have something like classMetaData which can
be a dictionary containing all the data like name of the class, method
dictionary etc this way we ensure that what happened with name does not
happen with other methods too that may find themselves in a name conflict
by an unaware user.

Or we can provide both ways or something else.

Class name has caused me pain too and I am no newbie , when I was making an
API for Blender it clashed with the name of the 3d objects. So this is
definitely not newbie orientated problem , its a fundamental problem.

I dont mind which solution you guys follow , afterall its easy to solve
cause its easy to override any solution I don't like. The beauty of
Smalltalk :)

On Mon, Aug 21, 2017 at 11:05 AM Marcus Denker <marcus.denker at inria.fr>
wrote:

>
> > On 20 Aug 2017, at 23:48, Brad <bsselfridge at gmail.com> wrote:
> >
> > I vote for setClassName:
> >
>
> setName: is better because this is what is there since many many years…
> and by just using it
> we must need to deprecate one method, not two.
>
>         Marcus
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20170821/f6987dca/attachment.html>


More information about the Pharo-dev mailing list