[Pharo-dev] [Gsoc] [FastTable improvements] [Features request]

Guillermo Polito guillermopolito at gmail.com
Sat Apr 1 09:06:34 EDT 2017


I understand that the data source we have right now is too low level. I'd
prefer to call it "Cell data source" rather than view as it is more
specific to the table, unless we want to reuse it in other scenarios....

Now, maybe part of GSOC could be to provide a higher-level provider able to
nicely map domain objects to cells, wether it is text, icons, pictures,
morphs, widgets.

On Fri, Mar 31, 2017 at 7:24 PM, Stephane Ducasse <stepharo.self at gmail.com>
wrote:

> I read and could not understand. Now what I see is that there are view in
> the class name.
> So at least dataSource should be called dataSourceViewProvider.
>
> On Fri, Mar 31, 2017 at 9:56 AM, Stephan Eggermont <stephan at stack.nl>
> wrote:
>
>> On 31/03/17 08:14, Stephane Ducasse wrote:
>>
>>> To me a datasource should deliver data and not UI elements.
>>>
>>
>> AFAIK it is an old established designation for this.
>> It is the data source of the table view, not of the persistency
>> layer. It provides a single point of access to the data in a form that
>> the table view can understand, which is cells.
>>
>> https://developer.apple.com/reference/uikit/uitableviewdatasource
>> https://developer.apple.com/reference/uikit/uitableviewdelegate
>>
>> Stephan
>>
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20170401/ecb81490/attachment-0002.html>


More information about the Pharo-dev mailing list