[Pharo-dev] Pharo RPi and FileSystem error

Jean Baptiste Arnaud jbaptiste.arnaud at gmail.com
Wed Apr 30 12:49:34 EDT 2014


That the point I want to checks it, run test and if work integrated for raspbian.
It is completely generated it shouldn't have any problem. But ...

A really nice guy can just do the image side hack to avoid FileSystem error.

On 30 Apr 2014, at 18:24, Douglas McPherson <djm1329 at san.rr.com> wrote:

> As a data point, OSProcess works "out-of-the-box" with the Squeak interpreter VM shipped with Raspbian. So should be ok in Pharo, but I haven't tried it.
> 
> Doug
> 
> On Apr 30, 2014, at 09:03 , David T. Lewis wrote:
> 
>>> 
>>> There are no NativeBoost on Rpi, FFI or OSProcess.
>>> Basically the fileSystem work, but some data are fetch via env variable
>>> and then NativeBoost.
>>> The solution is to bypass all the request of env variable.
>>> You should use another way until, we finish to integrate a way to request
>>> correctly the env variable (NB on arm).
>>> 
>>> I will studies the possibility to reintegrate fast the OSProcess plugin to
>>> offer "better" solution.
>> 
>> 
>> I would expect OSProcess to work without problems on Rpi, although I do
>> not have a way to test it. The plugin should be fine. Maybe some changes
>> will be needed on the image side for detecting the platform, I'm not sure.
>> 
>> Let me know if I can help, I will be glad to add any necessary patches to
>> OSProcess.
>> 
>> Dave
>> 
>> 
> 
> 



Best Regards
Jean Baptiste Arnaud
jbaptiste.arnaud at gmail.com







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20140430/4236ca5d/attachment-0002.html>


More information about the Pharo-dev mailing list