[Pharo-dev] Pharo RPi and FileSystem error

Jean Baptiste Arnaud jbaptiste.arnaud at gmail.com
Wed Apr 30 07:19:09 EDT 2014


This bug turn around since the first release of Rpi VM, 
It can be solve completely in the image side by just patching it. Until we have a better solution.

We used in the 3.0 image NativeBoost to get all the env variable.
So when you ask origin it try NativeBoost, that do not work. And UnixResolver raises this exception.

There are no NativeBoost on Rpi, FFI or OSProcess.
Basically the fileSystem work, but some data are fetch via env variable and then NativeBoost.
The solution is to bypass all the request of env variable. 
You should use another way until, we finish to integrate a way to request correctly the env variable (NB on arm).

I will studies the possibility to reintegrate fast the OSProcess plugin to offer "better" solution.
But here we will have a special case for the UnixResolver isNBWorkingOnThisVM.
That will be remove when the asmjit arm will be finish.

On 30 Apr 2014, at 12:01, jannik laval <jannik.laval at gmail.com> wrote:

> Hi all,
> 
> I have an error on Pharo 3, with RPi.
> The error is UnixResolver>>Can't find the request origin
> 
> To reproduce it, just run this line:
> ---
> FileLocator home exists
> 
> 
> Thank you for your help.
> -- 
> ~~Jannik Laval~~
> École des Mines de Douai
> Enseignant-chercheur
> http://www.jannik-laval.eu
> http://www.phratch.com
> http://car.mines-douai.fr/
> 

Best Regards
Jean Baptiste Arnaud
jbaptiste.arnaud at gmail.com







-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20140430/38dfee35/attachment-0002.html>


More information about the Pharo-dev mailing list