[Pharo-dev] Closure vs BlockClosure
mkroehnert42 at googlemail.com
Thu Apr 17 11:23:10 EDT 2014
I just wanted to mention that Apple also added 'Closures' as 'Blocks' to
Objective-C (respectively C):
On Thu, Apr 17, 2014 at 4:45 PM, Yuriy Tymchuk <yuriy.tymchuk at me.com> wrote:
> It’s like saying that we have to run Pharo on JVM because everyone is
> doing that. In 80s block was invented. Why should we rename it because of
> some other languages?
> On 17 Apr 2014, at 16:35, Alexandre Bergel <alexandre.bergel at me.com>
> > Well… the whole community of programming language call a closure a
> closure. Calling a block what is actually a closure may not be a
> well-marketed move in my opinion.
> > Alexandre
> > --
> > _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
> > Alexandre Bergel http://www.bergel.eu
> > ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
> > On Apr 17, 2014, at 10:29 AM, Sebastian Sastre <
> sebastian at flowingconcept.com> wrote:
> >> On Apr 17, 2014, at 10:08 AM, Yuriy Tymchuk <yuriy.tymchuk at me.com>
> >>> I would rather rename is to Block, as everyone is calling it a “block”.
> >> That might be actually a good idea
> >> sebastian
> >> o/
> >> PS: thinking in that line there is also ‘Context’ as, conceptually,
> what these blocks of code want to do is to keep the evaluation in a
> specific context. But to ease know-how transference and type less I’d
> rather go with the most popular name, as you suggested: ‘Block'
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Pharo-dev