[Pharo-dev] Closure vs BlockClosure

Max Leske maxleske at gmail.com
Thu Apr 17 09:42:20 EDT 2014


I usually say “block” but I have nothing against a name change. I think “closure” would be an intention revealing name, I like it. And I’m willing to say “closure” from now on :)


On 17.04.2014, at 15:35, Alexandre Bergel <alexandre.bergel at me.com> wrote:

> Well… the whole community of programming language call a closure a closure. Calling a block what is actually a closure may not be a well-marketed move in my opinion.
> 
> Alexandre
> -- 
> _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
> Alexandre Bergel  http://www.bergel.eu
> ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
> 
> 
> 
> On Apr 17, 2014, at 10:29 AM, Sebastian Sastre <sebastian at flowingconcept.com> wrote:
> 
>> On Apr 17, 2014, at 10:08 AM, Yuriy Tymchuk <yuriy.tymchuk at me.com> wrote:
>> 
>>> I would rather rename is to Block, as everyone is calling it a “block”.
>> 
>> That might be actually a good idea
>> 
>> sebastian
>> 
>> o/
>> 
>> PS: thinking in that line there is also ‘Context’ as, conceptually, what these blocks of code want to do is to keep the evaluation in a specific context. But to ease know-how transference and type less I’d rather go with the most popular name, as you suggested: ‘Block'
>> 
>> 
> 
> 





More information about the Pharo-dev mailing list