[Pharo-dev] Random VM crashes

Eliot Miranda eliot.miranda at gmail.com
Wed Apr 9 14:50:25 EDT 2014


On Wed, Apr 9, 2014 at 6:09 AM, Esteban Lorenzano <estebanlm at gmail.com>wrote:

> Hi,
>
> PharoDebug.log and crash,dmp could be helpful also, to understand what
> happens.
>

And compiling an assert VM and running it from the command line to see any
assert-fails.  It could be a VM bug.


>
> Esteban
>
>
> On 09 Apr 2014, at 15:01, J.F. Rick <self at je77.com> wrote:
>
> Cool! I am using SVG files so there might be some unicode data being sent
> to Cairo buffer. On the other hand, my crash happens randomly, rather than
> as a result of a specific repeatable action. It sounds like this would be
> more along the lines of a repeatable sequence.
>
> Anyway, I'll update the code and see if it helps. Again, this problem is
> difficult to diagnose as the crash only happens every other day. Even if it
> doesn't happen all week, it doesn't mean that that was the problem. For
> instance, there have been no crashes today, so it makes me think that the
> multi-touch support, rather than Athens, is the culprit.
>
> Cheers,
>
> Jeff
>
>
> On Wed, Apr 9, 2014 at 2:12 PM, Igor Stasenko <siguctua at gmail.com> wrote:
>
>>
>>
>>
>> On 9 April 2014 13:55, J.F. Rick <self at je77.com> wrote:
>>
>>> Hi,
>>>
>>> when I have one of my multi-touch programs open, Pharo occasionally
>>> (read once every few days) just crashes. Ubuntu mentions a failure to
>>> report to Ubuntu on the pharovm but I'm not sure how to understand that
>>> failure.
>>>
>>> I thought it might be one of two things: (1) some sort of problem with
>>> Athens rendering or (2) some sort of problem with the multi-touch events.
>>> Those are really the only things that separate when I'm developing and when
>>> I'm testing. It never crashes when I'm developing, which is a much larger
>>> percentage of the time. Recently, the crash happened when I was not
>>> touching the display. That meant that there would not have been any touch
>>> events to process, nor would an Athens render happen. Strange.
>>>
>>> I'm not sure how to proceed. I've turned off the multi-touch support for
>>> the time being to see if it still happens. If so, that would probably
>>> exonerate the multi-touch code. Does anyone else have rare random
>>> unexplained crashes happening while using Athens? Is there anything I could
>>> do to better diagnose the problem. It's fiendish as it happens so rarely
>>> and there is no replicable action that causes it to happen.
>>>
>>> i fixed recently this one:
>>
>>
>> https://pharo.fogbugz.com/f/cases/13184/Fix-encoder-for-displaying-high-range-unicode-chars
>>
>> could be it?
>>
>>
>>> Cheers,
>>>
>>> Jeff
>>>
>>> --
>>> Jochen "Jeff" Rick, Ph.D.
>>> http://www.je77.com/
>>> Skype ID: jochenrick
>>>
>>
>>
>>
>> --
>> Best regards,
>> Igor Stasenko.
>>
>
>
>
> --
> Jochen "Jeff" Rick, Ph.D.
> http://www.je77.com/
> Skype ID: jochenrick
>
>
>


-- 
best,
Eliot
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20140409/fc346e15/attachment-0002.html>


More information about the Pharo-dev mailing list