[Pharo-dev] FogBugz (Case [Issue]13154) Pharo VM - BitBlt bug in alphaSourceBlendBits8

Nicolai Hess nicolaihess at web.de
Wed Apr 2 03:08:55 EDT 2014


2014-04-01 0:31 GMT+02:00 Nicolas Cellier <
nicolas.cellier.aka.nice at gmail.com>:

>
> 2014-03-31 23:58 GMT+02:00 Nicolai Hess <nicolaihess at web.de>:
>
> Thank you Nicolas,
>> I verified the fix, it works.
>>
>> I took nicolas' change and build a windows pharo vm. changing the bit
>> depth
>> to 8bit littleendian (-8) works now.
>>
>>
> hey, you made the major contribution : find the bug and suggest a
> correction!
> http://bugs.squeak.org/view.php?id=7247
>
>
>> But there are two more issues (not related to this fix).
>> 1. Changing Display depth to 4/8/16 shows horrible rendering artifacts
>>    (those do not occur on squeak)
>>
>
> could it be related to issue 13057?
>

No. At least it is not solved by fixing that.
Maybe it is related to the fast bitblitting, but I don't think so, and it
is in
pharo only.




>
>
>> 2. Since refactoring some parts out of DisplayScreen into
>> MorphicUIManager you
>> can not change the depth from -XX to XX
>> Display newDepth:8
>> has no effect if current display depth is -8.
>> (This happens on squeak too, verified in Squeak 4.4/Squeak 4.5).
>>
>>
> Hmm, bad, but certainly not an operation tested everyday :)
>
>
>>
>> BTW found this change for alphaSourceBlendBits8 its way into squeaks vm?
>> I took the lates 4.5 allinone and the bug is still there.
>>
>> regards
>>
>>
> It's in both VMMaker and VMMaker.oscog head revisions for sure.
> But I don't know which VM was included in the distribution.
> Squeak VM production is not as engineered as the Pharo one, I think it's
> hand-crafted, and the MacOSX version lacks hands now, so it might be
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20140402/04965a04/attachment-0002.html>


More information about the Pharo-dev mailing list