[Pharo-dev] Large difference in image size when loading configuration

phil at highoctane.be phil at highoctane.be
Mon Nov 11 06:30:40 EST 2013


[User.Techlab] → du -hs package-cache
5.3M    package-cache

Phil

On Mon, Nov 11, 2013 at 11:41 AM, Sven Van Caekenberghe <sven at stfx.eu>wrote:

> What is the total size of the package-cache, like du -hs ?
> Could it be the same size of the difference in image size ?
> That would mean that the contents of the packages themselves is cached in
> the image...
>
> On 11 Nov 2013, at 10:39, phil at highoctane.be wrote:
>
> > I am experiencing the following while loading my configuration.
> >
> > REPO=http://www.smalltalkhub.com/mc/philippeback/HOWebStack/main
> > ./pharo Pharo.image config $REPO ConfigurationOfHOWebStack --install=0.4
> >
> > Everything loads fine.
> >
> > But:
> >
> > with a package-cache/ empty, the final image is: 44.452.060 with a
> changes file of: 10.831.877
> >
> > with a primed package-cache (meaning, letting the mczs in place and
> starting with a fresh image), the final image is: 29.480.912 with a changes
> file of: 10.830.899
> >
> > That's quite a huge difference.
> >
> > I tried again to be sure (fresh image and empty package-cache, then
> fresh image only) and, weirdly enough, even if the difference in size was
> the same, the sizes themselves weren't.the same...
> >
> > 44.446.152 - 10.830.899
> > 29.986.284 - 10.831.543
> >
> > Maybe that's due to a GC occurring differently between the two.
> >
> > But this gives the impression that one cannot load a base image, apply a
> configuration, and end up with the same image twice. Weird.
> >
> > Why is this difference so large in the first place ?
> >
> > Phil
> >
> >
> >
> >
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20131111/bb45e4ad/attachment-0002.html>


More information about the Pharo-dev mailing list