[Pharo-dev] strange bug when opening the morph menu

Tudor Girba tudor at tudorgirba.com
Sun Dec 15 05:29:53 EST 2013


Exactly, Nicolai!

Thanks for reproducing. I added your description to the issue.

Essentially, I just wanted to get the halo menu in order to export a
debugger window to png.

Doru


On Sat, Dec 14, 2013 at 10:26 PM, Nicolai Hess <nicolaihess at web.de> wrote:

> If you press and hold the mousebutton the menu is visible.
> If you just click the mousebutton the menu flashes for a short time
> and the window is in "grab" mode.
> Actually the grab-menu item is selected, because the menu
> is such wide, that it does not open beneath the mouse pointer,
> and so the mouse pointer is always over some menu item.
> (at leas with on windows)
>
> If you have a normal workspace title bar, the menu stays on even if
> you just click the mousebutton.
>
> nicolai
>
>
>
> 2013/12/14 Stéphane Ducasse <stephane.ducasse at inria.fr>
>
>>
>>
>> Hi,
>>
>> Try this:
>>
>> 1. Execute
>> Workspace open
>> 2. Try to get the menu of the window
>> ==> it opens just fine
>>
>> 1. Execute
>> Workspace open label: (1 to: 100) asOrderedCollection asString
>> 2. Try to get the menu of the window
>> ==> it does not open properly (it opens large and it closes quickly) and
>> the mouse remains in dragging mode
>>
>>
>> I do not get this problem.
>> When I want to edit the title it just takes the complete screen width.
>>
>>
>> I opened a bug report:
>>
>> https://pharo.fogbugz.com/f/cases/12426/Morph-menu-has-strange-behavior-when-the-Morph-label-is-too-large
>>
>> Does anyone have any idea of why it happens?
>>
>> Cheers,
>> Doru
>>
>>
>> --
>> www.tudorgirba.com
>>
>> "Every thing has its own flow."
>>
>>
>>
>


-- 
www.tudorgirba.com

"Every thing has its own flow"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20131215/d0c586b8/attachment-0002.html>


More information about the Pharo-dev mailing list