[Pharo-dev] methodDict versus methodDictionary
stephane.ducasse at inria.fr
Sat Dec 14 16:13:10 EST 2013
I do not understand why we deprecate methodDictionary and not methodDict (What a really bad name)
I hate this inconsistent and lame name like methodDict and
Marcus you mention on the bug entry
nobody should access methodDict directly
-> so why have a "nice" accessor for something not to be used?
but I have 103 send of methodDict in my image
So I do not get it and personally I would not deprecate methodDictionary and I would remove
methodDict because it sucks!
In the same bad style instSize or instSpec looks like the guy was lazy to type instanceSize and instanceSpec
So let me know because I want to understand the story behind methodDict the ugly.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Pharo-dev