[Pharo-dev] strange bug when opening the morph menu

Alexandre Bergel alexandre.bergel at me.com
Sat Dec 14 10:57:11 EST 2013


Strange, I cannot reproduce the problem

Alexandre


On Dec 14, 2013, at 1:56 PM, Nicolai Hess <nicolaihess at web.de> wrote:

> Ah, that one. 
> I thought you meant the window menu from the little arrow icon on the right.
> 
> 
> 2013/12/14 Tudor Girba <tudor at tudorgirba.com>
> What do you mean by slow?
> 
> The problem is that the morph menu (Cmd+Shift+RightClick) does not open when the title is too large.
> 
> Cheers,
> Doru
> 
> 
> On Sat, Dec 14, 2013 at 12:01 PM, Alexandre Bergel <alexandre.bergel at me.com> wrote:
> I am not sure how to reproduce this.
> I do not see anything slow
> 
> Alexandre
> 
> 
> On Dec 14, 2013, at 11:10 AM, Tudor Girba <tudor at tudorgirba.com> wrote:
> 
> > Hi,
> >
> > Try this:
> >
> > 1. Execute
> > Workspace open
> > 2. Try to get the menu of the window
> > ==> it opens just fine
> >
> > 1. Execute
> > Workspace open label: (1 to: 100) asOrderedCollection asString
> > 2. Try to get the menu of the window
> > ==> it does not open properly (it opens large and it closes quickly) and the mouse remains in dragging mode
> >
> > I opened a bug report:
> > https://pharo.fogbugz.com/f/cases/12426/Morph-menu-has-strange-behavior-when-the-Morph-label-is-too-large
> >
> > Does anyone have any idea of why it happens?
> >
> > Cheers,
> > Doru
> >
> >
> > --
> > www.tudorgirba.com
> >
> > "Every thing has its own flow."
> 
> --
> _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
> Alexandre Bergel  http://www.bergel.eu
> ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
> 
> 
> 
> 
> 
> 
> 
> -- 
> www.tudorgirba.com
> 
> "Every thing has its own flow"
> 

-- 
_,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:
Alexandre Bergel  http://www.bergel.eu
^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.







More information about the Pharo-dev mailing list