[Pharo-dev] PharoSound load error in Pharo 2.0

jannik.laval jannik.laval at gmail.com
Mon Aug 19 16:01:35 EDT 2013


Please any help would be welcome.

You can find and read the configuration by evaluating:

=-=-=-=-=
Gofer it
      url: 'http://smalltalkhub.com/mc/JLaval/Phratch/main'
 	username: '' 
 	password: ''; 
      package: 'ConfigurationOfPhratch';
      load.
((Smalltalk at: #ConfigurationOfPhratch) project version: '1.0') record.
=-=-=-=-=

Jannik

On Aug 18, 2013, at 10:06 PM, jannik.laval <jannik.laval at gmail.com> wrote:

> I tried again and again without understanding…
> Now, what I have:
> If I inspect: " (ConfigurationOfPhratch project version: '1.0-baseline') record.", the version recorded is 5.4 (I am hoping to have 5.3)
> 
> ===
> a MetacelloNullRecordingMCSpecLoader(linear load : 
> 	linear load : 1.0-baseline [ConfigurationOfPhratch]
> 		load : ConfigurationOfOSProcess
> 	linear load : 1.0-baseline [ConfigurationOfPhratch]
> 		load : ConfigurationOfPharoSound
> 	linear load : 1.0-baseline [ConfigurationOfPhratch]
> 		linear load : 5.4 [ConfigurationOfPharoSound]
> 			load : Sound-StephaneDucasse.76
> 			load : Settings-Sound-HenrikSperreJohansen.2
> 			load : SoundScores-StephaneDucasse.6
> 			load : SoundMorphicUserInterface-StephaneDucasse.29
> 		[…]
> 		load : Phratch)
> ===
> 
> BUT, if I inspect "(ConfigurationOfPhratch project version: '1.0-baseline') ignoreImage: true; record.", It works fine. 
> 
> ===
> a MetacelloNullRecordingMCSpecLoader(linear load : 
> 	linear load : 1.0-baseline [ConfigurationOfPhratch]
> 		load : ConfigurationOfOSProcess
> 	linear load : 1.0-baseline [ConfigurationOfPhratch]
> 		load : ConfigurationOfPharoSound
> 	linear load : 1.0-baseline [ConfigurationOfPhratch]
> 		linear load : 5.3 [ConfigurationOfPharoSound]
> 			load : Sound-StephaneDucasse.75
> 			load : Settings-Sound-HenrikSperreJohansen.2
> 			load : SoundScores-StephaneDucasse.6
> 			load : Collections-Arithmetic-GuillermoPolito.4
> 			load : SoundMorphicUserInterface-StephaneDucasse.27
> 		[…]
> 		load : Phratch)
> ===
> 
> Why the ignoreImage change the behavior ?
> 
> Jannik
> 
> On Aug 18, 2013, at 10:27 AM, jannik.laval <jannik.laval at gmail.com> wrote:
> 
>> 
>> On Aug 18, 2013, at 10:18 AM, Stéphane Ducasse <stephane.ducasse at inria.fr> wrote:
>> 
>>> 
>>> On Aug 18, 2013, at 8:42 AM, jannik.laval <jannik.laval at gmail.com> wrote:
>>> 
>>>> Hum, I do not understand.
>>>> When I load it with your script it works (it loads the version 75 of Sound).
>>>> Now, with Phratch it tries to load the version 76 of Sound.
>>>> 
>>>> Here is my configuration:
>>>> 
>>>> ===
>>>> baseline10: spec
>>>> 	<version:'1.0-baseline'>
>>>> 	spec for: #common do: [
>>>> 			spec blessing: #baseline.
>>>> 			spec repository: 'http://smalltalkhub.com/mc/JLaval/Phratch/main'.
>>>> 			spec project: 'Sound' with: [
>>>> 				spec
>>>> 					repository: 'http://smalltalkhub.com/mc/PharoExtras/Sound/main'; 
>>>> 					versionString: #stable;
>>>> 					className: 'ConfigurationOfPharoSound'].
>>>> 			spec package: 'Phratch' with: [ 
>>>> 				spec requires: 'Sound'.
>>>> 			].
>>>> 	].
>>>> ===
>>>> 
>>> 
>>> did you try with '5.3'? to see
>> 
>> Yes, I tried and I have the same behavior.
>> There is something I do not understand, and the chapter about Metacello does not help me :(
>> 
>> Jannik
>> 
>> 
>>> 
>>>> And I load it with :
>>>> (ConfigurationOfPhratch project latestVersion: #baseline) load.
>>>> 
>>>> So, why does it not take the stable version of PharoSound ?
>>> 
>>> 
>>> I do not know. we should ask dale.
>>> 
>>>> 
>>>> Thanks for the help.
>>>> Jannik
>>>> 
>>>> 
>>>> 
>>>> On Aug 17, 2013, at 7:03 PM, Stéphane Ducasse <stephane.ducasse at inria.fr> wrote:
>>>> 
>>>>> jannik
>>>>> 
>>>>> 
>>>>> (ConfigurationOfPharoSound project version: '5.3') load
>>>>> 
>>>>> loads perfectly in 2.0
>>>>> 
>>>>> 
>>>>> stable: spec 
>>>>> 	<symbolicVersion: #stable>
>>>>> 	
>>>>> 	spec for: #'pharo1.0.x' version: '1.0'. 
>>>>> 	spec for: #'pharo1.1.x' version: '3.0'. 
>>>>> 	spec for: #'pharo1.2.x' version: '3.0'. 
>>>>> 	spec for: #'pharo1.4.x' version: '5.0'. 
>>>>> 	spec for: #'pharo2.0.x' version: '5.3'. 
>>>>> 	spec for: #'pharo3.0.x' version: '5.4'. 
>>>>> 
>>>>> (ConfigurationOfPharoSound project version: '5.3') load
>>>>> loads perfectly on a freshly downloaded 2.0 image
>>>>> 
>>>>> So tell me more.
>>>>> 
>>>>> Stef
>>>>> 
>>>>> 
>>>> 
>>>> 
>>> 
>>> 
>> 
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20130819/f35d9a6d/attachment-0002.html>


More information about the Pharo-dev mailing list