[Pharo-dev] PharoSound load error in Pharo 2.0

Stéphane Ducasse stephane.ducasse at inria.fr
Sun Aug 18 04:18:09 EDT 2013


On Aug 18, 2013, at 8:42 AM, jannik.laval <jannik.laval at gmail.com> wrote:

> Hum, I do not understand.
> When I load it with your script it works (it loads the version 75 of Sound).
> Now, with Phratch it tries to load the version 76 of Sound.
> 
> Here is my configuration:
> 
> ===
> baseline10: spec
> 	<version:'1.0-baseline'>
> 	spec for: #common do: [
> 			spec blessing: #baseline.
> 			spec repository: 'http://smalltalkhub.com/mc/JLaval/Phratch/main'.
> 			spec project: 'Sound' with: [
> 				spec
> 					repository: 'http://smalltalkhub.com/mc/PharoExtras/Sound/main'; 
> 					versionString: #stable;
> 					className: 'ConfigurationOfPharoSound'].
> 			spec package: 'Phratch' with: [ 
> 				spec requires: 'Sound'.
> 			].
> 	].
> ===
> 

did you try with '5.3'? to see

> And I load it with :
> (ConfigurationOfPhratch project latestVersion: #baseline) load.
> 
> So, why does it not take the stable version of PharoSound ?


I do not know. we should ask dale.

> 
> Thanks for the help.
> Jannik
> 
> 
> 
> On Aug 17, 2013, at 7:03 PM, Stéphane Ducasse <stephane.ducasse at inria.fr> wrote:
> 
>> jannik
>> 
>> 
>> (ConfigurationOfPharoSound project version: '5.3') load
>> 
>> loads perfectly in 2.0
>> 
>> 
>> stable: spec 
>> 	<symbolicVersion: #stable>
>> 	
>> 	spec for: #'pharo1.0.x' version: '1.0'. 
>> 	spec for: #'pharo1.1.x' version: '3.0'. 
>> 	spec for: #'pharo1.2.x' version: '3.0'. 
>> 	spec for: #'pharo1.4.x' version: '5.0'. 
>> 	spec for: #'pharo2.0.x' version: '5.3'. 
>> 	spec for: #'pharo3.0.x' version: '5.4'. 
>> 
>> (ConfigurationOfPharoSound project version: '5.3') load
>> loads perfectly on a freshly downloaded 2.0 image
>> 
>> So tell me more.
>> 
>> Stef
>> 
>> 
> 
> 





More information about the Pharo-dev mailing list