[Pharo-dev] about on:do: -> onKey:do:

Igor Stasenko siguctua at gmail.com
Mon Aug 5 05:57:56 EDT 2013


On 5 August 2013 10:32, Guillermo Polito <guillermopolito at gmail.com> wrote:
> Ok, I commited a slice with a different selector name we discussed with Ben
> a while ago. #bindKeyCombination:toAction:
>
> On Mon, Aug 5, 2013 at 9:42 AM, Igor Stasenko <siguctua at gmail.com> wrote:
>>
>> On 4 August 2013 15:50, Esteban Lorenzano <estebanlm at gmail.com> wrote:
>> > I would use #onKeyCombination:do:  to keep coherency with the framework.
>> >
>>
>> why not naming it
>> onKeyCombinationInKeyBindingsFramework:do:
>> :)
>
>
> Really?
>
>>
>>
>>
>>
>> OnKey: is good because it short.
>
>
> Short is not always better, come on igor!
>
>>
>> And not ambiguous (you can use single
>> key(s)
>
>
> yes but also...
>
>> as well as key combinations,
>
>
> And then why Key is ok? The role the object is playing there is the one of a
> key combination. If a key can be used as a key combination it is only
> circumstantial.
>
>>
>> but that details).
>
>
> You know better than a lot of people that details matter :). And now you can
> solve the detail instantaneously by just making the selector more intention
> revealing. I do not see the problem.
>

Well, it is always a tradeoff between being explicit and too elaborate.

Now, of course, you, as designer of key bindings know better, so i
won't argue about that.

Just thought that onKey:do: is explicit enough to indicate the intent
(and in any case, much better than on:do: ).




-- 
Best regards,
Igor Stasenko.




More information about the Pharo-dev mailing list