[Pharo-dev] is there anyone who can use SimpleMIDIPort on Mac OSX 10.6.8?

laurent laffont laurent.laffont at gmail.com
Sun Aug 4 12:35:13 EDT 2013


Hi,

I was looking about MIDI on Linux today, and may be that's related. On
Linux, for the MIDI plugin, there's 2 files:
- sqUnixMIDIALSA.inc
- sqUnixMIDINone.inc

it seems sqUnixMIDINone is build, and not ALSA one. In
/platforms/unix/plugins/MIDIPlugin/sqUnixMIDI.c:
#if defined(USE_MIDI_ALSA)
# include "sqUnixMIDIALSA.inc"
#else
# include "sqUnixMIDINone.inc"
#endif

USE_MIDI_ALSA is set in a configure script, and if I understand correctly,
it is not used with the cmake process ? Anyway, I've changed to:
#include "sqUnixMIDIALSA.inc"

and the file compile, but fail to link. It seems gcc doesn't have the
needed -l flag to link to alsa lib, but I don't know where to specify this
(I suppose somewhere in VMMaker ?)

Cheers,

Laurent





On Sun, Aug 4, 2013 at 5:09 PM, NISHIHARA Satoshi <goonsh at gmail.com> wrote:

> is there anyone who can use SimpleMIDIPort on Mac OSX 10.6.8?
>
> Stéphane Ducasse san told me that it can use MIDIPlugin in Pharo 2.0
> on Mac 10.8.3.
> but I can't use MIDIPlugin on Mac OSX 10.6.8.
>
> SimpleMIDIPort>>#midiIsSupported
>     -> false
> SimpleMIDIPort>>#primPortCount
>     -> 0
>
> vm:
>     Pharo.app(13/03/13)
>     Pharo-126.app(13/05/04)
>     Pharo-145.app(13/05/31)
>     Pharo-169.app(13/07/10)
>     Pharo-186.app(13/07/15)
>     Pharo-187.app(13/07/19)
>     Pharo-188.app(13/07/31)
>
> I would like to know whether it is a problem of all those that are
> using 10.6.8 or personal trouble.
>
> -p.s.-
>
> On Eliot Miranda san's CogMT.r2761.app and Cog.r2761.app,
> SimpleMIDIPort>>#midiIsSupported
>     -> true
> SimpleMIDIPort>>#primPortCount
>     -> 1
>
> regards.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20130804/a62aa4b6/attachment-0002.html>


More information about the Pharo-dev mailing list