[Pharo-dev] Fuel API bug

Stéphane Ducasse stephane.ducasse at inria.fr
Sun Aug 4 10:10:04 EDT 2013

Hi guys

can you rename this method?

on: aCollectionOrStream do: aBlock
	"Evaluates a block with a new stream based on the collection or stream. Answers the result of the block evaluation. Follows the style of FileStream>>fileNamed:do:."
	| aStream |
	aStream := self on: aCollectionOrStream.
	[ ^ aBlock value: aStream ] ensure: [ aStream close ]

Please do not use on:do: for something that is not about exception (and announcements).

It is too confusing and refactor after.


More information about the Pharo-dev mailing list