[Pharo-dev] Windows problem with FilePlugin ?

Benjamin Benjamin.VanRyseghem.Pharo at gmail.com
Thu Aug 1 10:16:30 EDT 2013


Yep :)

Thanks for your help.
I opened an issue for that (11293) and I will try to tackle it tonight

Ben

On Aug 1, 2013, at 4:11 PM, Stéphane Ducasse <stephane.ducasse at inria.fr> wrote:

> Igor did not tell you but I see strange blue window and windows on his machine and red square of death…. 
> So he is looking at it.
> 
> Stef
> 
> On Aug 1, 2013, at 1:01 PM, Benjamin <benjamin.vanryseghem.pharo at gmail.com> wrote:
> 
>> On my image, when opened in Windows, opening the File Browser leads to a red square of death :s
>> 
>> And using the UIManager to popup the file picker leads to an infinite loop of halt :s
>> 
>> Do you experienced that too ?
>> 
>> 
>> Can people using windows try the following line:
>> 
>> (FileSystem disk root) directories
>> 
>> This gives me C:, D:, F:, G: where actually only C: and G: are present…
>> 
>> 
>> It seems to come from
>> DiskStore>>#basicEntry:path:nodesDo:
>> […]
>> 
>> [ entry isNil ]
>> 	whileFalse: [
>> 		entry at: 1 put: (Primitives decode: entry first).
>> 		aBlock value: entry.
>> 		index := index + 1.
>> 		entry := Primitives lookupEntryIn: encodedPathString index: index ].
>> 
>> So I would say it comes from the primitives.
>> 
>> Ben
> 
> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20130801/ac20aa82/attachment-0002.html>


More information about the Pharo-dev mailing list