[Pharo-project] Needs help with hang images

Eliot Miranda eliot.miranda at gmail.com
Fri Mar 23 14:05:52 EDT 2012


On Fri, Mar 23, 2012 at 3:13 AM, Denis Kudriashov <dionisiydk at gmail.com>wrote:

> Hello.
>
> I have standalone application with UI which hangs sometime (very *rarely*)
> .
> This application has many threads which interacts with server.
> All interactions with server and UI activity logged.
>
> But at hang state there are no new log entries. There are no server
> interactions.
> It looks like all VM block image stuff. ("alt ." not work too).
> Logs always finished at same position. I know where I should add extra
> logging which give me information before hang.
>
> So I need help.
> What information about system can help me? What code I should use?
> Is somebody has same problems?
>
> Application uses old cog VM (maybe one of first distributions from Eliot)
> and Pharo1.1.
> Application uses continuations actively.
> I want try updated VM. What version I should use? I need most reliable cog
> (not latest I think).
>

The latest is likely to be the most reliable.  Cog is pretty stable right
now and is getting bug fixes. When significant new development happens this
will change.  But right now the latest VMs in
http://www.mirandabanda.org/files/Cog/VM/ are the best ones I build to use,
and Igor can point you to the best ones he builds.


> Best regards,
> Denis
>
>


-- 
best,
Eliot
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20120323/976ec870/attachment-0001.html>


More information about the Pharo-dev mailing list