[Pharo-project] NativeBoost VM's

Igor Stasenko siguctua at gmail.com
Sun Mar 4 16:04:21 EST 2012


On 4 March 2012 22:46, Jan van de Sandt <jvdsandt at gmail.com> wrote:
> Hello,
>
> On the Pharo Jenkins server [1] there is a recent build of a VM with
> NativeBoost support for the Mac. But the Unix version is six months old and
> there is no Windows version.

The Unix one was not built because i forgot to set the upstream project, :)
so build doesn't triggers when everything else builds.
The Windows one, i was built manually on my machine, because we were lacking
windows slave for jenkins.
You can download windows VM from nativeboost project downloads page:
http://code.google.com/p/nativeboost/downloads/list

I'm not happy with VM i built (Cog + NativeBoost Win32 Binaries (7 Feb, 2012) ).
I built the threaded VM, and besides the warning which pops up every
time you launch it,
i had couple crashes when simply loading MC packages.
I am still not sure what happens, and need to investigate, because the
other VM i built recently
on another windows machine (by installing everything from scratch)
behaves quite stable.

>
> Is this just a Jenkins issue and is NativeBoost working on Unix and Windows?
> Or are these platforms not working yet?
>
Everything is working. It is just jenkins.
I hope in following few days, after we deal with weird free space
issues on jenkins,
we can finally set up windows builds for vanilla vms as well as for nativeboost.

> Jan.
>
> [1] https://ci.lille.inria.fr/pharo/view/NativeBoost/



-- 
Best regards,
Igor Stasenko.




More information about the Pharo-dev mailing list