[Pharo-project] problem: nautilus forked moose-algos

Mariano Martinez Peck marianopeck at gmail.com
Sun Mar 4 09:22:00 EST 2012


On Sun, Mar 4, 2012 at 2:39 PM, Tudor Girba <tudor at tudorgirba.com> wrote:

> Hi,
>
> I saw that you removed the problematic parts, but now
> CofigurationOfNautilus throws a loading error, because MonticelloAnnouncer
> is not present when NautilusMCBindings gets loaded.
>

Are you loading in the LASTEST pharo core 1.4?  I think MonticelloAnnouncer
was added just recently (in fact, for Nautilus).

Cheers


>
> Could you take a look?
>
> Cheers,
> Doru
>
>
> On 3 Mar 2012, at 23:42, Benjamin wrote:
>
> > I will remove that and push it into another repo.
> >
> > It was a plugin started by Jannik, but never finished :)
> >
> > Thanks for report :)
> >
> > Ben
> >
> > On Mar 3, 2012, at 9:41 PM, Tudor Girba wrote:
> >
> >> Hi,
> >>
> >> Nautilus includes NautilusCommon and this in turn includes
> NautilusCommon-Plugin-JannikAlgo which copies verbatim a part of the
> classes from the Moose-Algos-Graph package from
> http://www.squeaksource.com/MooseAlgos.
> >>
> >> These classes are used in a plugin. Because of this, we cannot use
> Nautilus in Moose.
> >>
> >> So, I would suggest one of these:
> >> - remove the plugin, at least from the default configuration
> >> - load Moose-Algos-Graph properly
> >> - fork with a different name
> >>
> >> Cheers,
> >> Doru
> >>
> >>
> >> --
> >> www.tudorgirba.com
> >>
> >> "Yesterday is a fact.
> >> Tomorrow is a possibility.
> >> Today is a challenge."
> >>
> >>
> >>
> >>
> >
> >
>
> --
> www.tudorgirba.com
>
> "Obvious things are difficult to teach."
>
>
>
>
>


-- 
Mariano
http://marianopeck.wordpress.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20120304/59af4638/attachment-0001.html>


More information about the Pharo-dev mailing list