[Pharo-project] Small usability glitch

Camillo Bruni camillobruni at gmail.com
Thu Mar 1 16:20:35 EST 2012


true :)

found the bug, patch on the way.

can you open a bug report?

best
cami

On 2012-03-01, at 21:50, Sebastian Sastre wrote:

> just for reference, it doesn't in today's one
> 
> Pharo1.4a
> Latest update: #14369
> 
> sebastian
> 
> o/
> 
> 
> On Mar 1, 2012, at 4:32 PM, Benjamin wrote:
> 
>> It works in Nautilus with almost the latest Pharo
>> 
>> 
>> Ben
>> 
>> On Mar 1, 2012, at 8:30 PM, Camillo Bruni wrote:
>> 
>>> Hi sebastian
>>> 
>>> This actually used to work that way.
>>> Will check
>>> 
>>> Best
>>> Cami
>>> 
>>> 
>>> -----Original message-----
>>> From: Sebastian Sastre <sebastian at flowingconcept.com>
>>> To: Pharo-project at lists.gforge.inria.fr
>>> Sent: 2012 Mar, Thu, 1 19:25:01 GMT+00:00
>>> Subject: [Pharo-project] Small usability glitch
>>> 
>>> Hey guys,
>>> 
>>> when opening a SystemBrowser and executing a "Find class..."  command (with context menu or cmd-f with focus in the packages pane) there is a dialog listing the classes that matches whatever you type.
>>> 
>>> So far so great.
>>> 
>>> The problem is that time and again I use the arrows keys to select the one that I was looking for and press enter only to get a dialog closed in a no-op.
>>> 
>>> Note that:
>>> 1. to make that dialog work, the only way is to use the mouse to click on OK or double click the target class and
>>> 2. the input even says: "Hit return to accept"
>>> 
>>> so..
>>> 
>>> sebastian
>>> 
>>> o/
>>> 
>>> 
>>> 
>>> 
>> 
> 
> 
> 





More information about the Pharo-dev mailing list