[Pharo-project] Tests jobs are non-functional

Guillermo Polito guillermopolito at gmail.com
Sat Jun 2 21:05:02 EDT 2012


Found it!

That test is sending twice the ClassRemoved event, the first succeeds, but
on the second one fails because the class is not registered any more.

I was trying this afternoon to replace the ugly ^nil by testing methods +
exceptions, but I died in the trial.  Tomorrow will be a new day :)

On Sun, Jun 3, 2012 at 1:13 AM, Igor Stasenko <siguctua at gmail.com> wrote:

> Looks like the problem with Pharo-2.0-AfterRunningTests.st
>
>
>
> Notice: Errors in script loaded from
>
> /builds/jenkins/workspace/Pharo-2.0-Tests/Architecture/32/OS/linux/Pharo-2.0-AfterRunningTests/
> Pharo-2.0-AfterRunningTests.st
>
> ===============================================================================
>  [0m [0m [31m==== Startup Error: MessageNotUnderstood: receiver of
> "removeClassDefinitionNamed:" is nil
>  [0mUndefinedObject(Object)>>doesNotUnderstand:
> #removeClassDefinitionNamed:
> RPackageOrganizer>>fullyRemoveClassNamed:
> RPackageOrganizer>>systemClassRemovedActionFrom:
> MessageSend>>value:
> MessageSend>>cull:
> MessageSend>>cull:cull:
> AnnouncementSubscription>>deliver: in Block: [action cull:
> anAnnouncement cull: announcer]
> BlockClosure>>on:do:
> BlockClosure>>on:fork:
> AnnouncementSubscription>>deliver:
>  [0m [31mGot startup errors:
>  [0m [31m    MessageNotUnderstood: receiver of
> "removeClassDefinitionNamed:" is nil
>  [0mbuild.sh: error loading code
>
> (/builds/jenkins/workspace/Pharo-2.0-Tests/Architecture/32/OS/linux/vm/CogVM)
>
>
> --
> Best regards,
> Igor Stasenko.
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pharo.org/pipermail/pharo-dev_lists.pharo.org/attachments/20120603/a10b5652/attachment-0001.html>


More information about the Pharo-dev mailing list