[Pharo-project] ConfigurationOfMagritte30

Stéphane Ducasse stephane.ducasse at inria.fr
Wed Jun 27 03:34:11 EDT 2012


Ok and I'm happy since I wrote a complete section (section 1.11) on that in the Metacello book chapter and everything is explained.
I just totally forgot and was sleepy (too many decontracting pills do not help my mind).
so forget the post.
Now I found some bugs in the chapter before that section and will fix them.

Stef


On Jun 27, 2012, at 9:24 AM, Stéphane Ducasse wrote:

> Of course I meant
> 
> 
>> stable: spec 
>> 	<symbolicVersion: #stable>
>> 	
>> 	spec for: #'1.3.x' version: '3.0'. 
>> 	spec for: #'1.3.x' version: '3.0'.
> 
> 
> 
> Now dale what is the meaning of common when we have?
> Does metacello know automatically that it should load common + pharo?
> 
> 
> baseline300: spec
> 	<version: '3.0-baseline'>
> 
> 	spec for: #'common' do: [
> 		spec blessing: #'baseline'.
> 		spec author: 'NickAger'.
> 		spec timestamp: '01/30/2011 11:02:07'.
> 		spec repository: 'http://source.lukas-renggli.ch/magritte3'.
> 		spec 
> 			project: 'Grease' with: [
> 				spec
> 					className: 'ConfigurationOfGrease';
> 					versionString: #'stable';
> 					loads: #('Core' );
> 					repository: 'http://www.squeaksource.com/MetacelloRepository' ];
> 			project: 'Seaside30' with: [
> 				spec
> 					className: 'ConfigurationOfSeaside30';
> 					versionString: #'stable';
> 					loads: #('Core');
> 					repository: 'http://www.squeaksource.com/MetacelloRepository' ].
> 		spec 
> 			package: 'Magritte-Model' with: [
> 				spec requires: #('Grease' ) ];
> 			package: 'Magritte-Tests-Model' with: [
> 				spec requires: #('Magritte-Model' ) ];
> 			package: 'Magritte-Seaside' with: [
> 				spec requires: #('Magritte-Model' 'Seaside30' ) ];
> 			package: 'Magritte-Deprecated' with: [
> 				spec requires: #('Magritte-Model') ].
> 		spec 
> 			group: 'default' with: #('Core' );
> 			group: 'Core' with: #('Magritte-Model' );
> 			group: 'Tests' with: #('Magritte-Tests-Model' );
> 			group: 'Seaside' with: #('Magritte-Seaside');
> 			group: 'Deprecated' with: #('Magritte-Deprecated') ].
> 
> 	spec for: #'pharo' do: [
> 		spec 
> 			package: 'Magritte-Model' with: [
> 				spec includes: #('Magritte-Pharo-Model' ). ];
> 			package: 'Magritte-Tests-Model' with: [
> 				spec includes: #('Magritte-Tests-Pharo-Model' ). ];
> 			package: 'Magritte-Seaside' with: [
> 				spec includes: #('Magritte-Pharo-Seaside' ). ];
> 			package: 'Magritte-Pharo-Model' with: [
> 				spec requires: #('Magritte-Model' ). ];
> 			package: 'Magritte-Tests-Pharo-Model' with: [
> 				spec requires: #('Magritte-Pharo-Model' ). ];
> 			package: 'Magritte-Pharo-Seaside' with: [
> 				spec requires: #('Magritte-Seaside' ). ];
> 			package: 'Magritte-Morph' with: [
> 				spec requires: #('Magritte-Model' ). ];
> 			package: 'Magritte-Pharo-Tools' with: [
> 				spec requires: #('Magritte-Deprecated' ). ].
> 		spec
> 			group: 'Tools' with: #('Magritte-Pharo-Tools') ].
> 		
> 	spec for: #gemstone do: [
> 		spec project: 'GsCore' with: [
> 			spec
> 				className: 'ConfigurationOfGsCore';
> 				versionString: #'bleedingEdge';
> 				repository: 'http://seaside.gemstone.com/ss/MetacelloRepository' ].		
> 		spec 
> 			package: 'Magritte-Model' with: [
> 				spec 
> 					requires: #('GsCore' );
> 					includes: #('Magritte-GemStone-Model' ). ];
> 			package: 'Magritte-Tests-Model' with: [
> 				spec includes: #('Magritte-Tests-GemStone-Model' ). ];
> 			package: 'Magritte-Seaside' with: [
> 				spec includes: #('Magritte-GemStone-Seaside' ). ];
> 			package: 'Magritte-GemStone-Model' with: [
> 				spec requires: #('Magritte-Model' ). ];
> 			package: 'Magritte-Tests-GemStone-Model' with: [
> 				spec requires: #('Magritte-GemStone-Model' ). ];
> 			package: 'Magritte-GemStone-Seaside' with: [
> 				spec requires: #('Magritte-Seaside' ) ] ]
> 
> 
>> Hi guys
>> 
>> I'm checking magritte 30 to write a updated chapter for the seaside book on magritte and the configurationOfMagritte30 seems wrong to me
>> the stable declaration is 
>> 
>> stable: spec 
>> 	<symbolicVersion: #stable>
>> 	
>> 	spec for: #'common' version: '3.0'. 
>> 
>> 
>> while it should be more 
>> 	
>> stable: spec 
>> 	<symbolicVersion: #stable>
>> 	
>> 	spec for: #'common' version: '1.3.x'. 
>> 	spec for: #'common' version: '1.4.x'.
>> 
>> Do you know if magritte30 works on pharo 1.3? and 1.4? 
>> 
>> 
>> I will also change MagicMagritte (I do not know if I have write access to it).
>> because stable is 
>> 
>> stable: spec 
>> 	<symbolicVersion: #stable>
>> 	
>> 	spec for: #'common' version: '1.0'
>> 
>> but I bet that nick (which is on holiday) works with pharo10. I guessed he misunderstood the stable meaning.
>> Stef 
>> 
>> 
> 
> 





More information about the Pharo-dev mailing list