[Pharo-project] Sticky morph after progress morph use

Stéphane Ducasse stephane.ducasse at inria.fr
Mon Jun 25 07:30:29 EDT 2012


Hi hilaire

we do not know (at least I do not know what happened with the old progress bar).
Now in 2.0 it is fixed (yes I know that you need a 1.4 version).

Stef

On Jun 24, 2012, at 12:14 PM, Hilaire Fernandes wrote:

> Hello,
> 
> With Pharo 1.4 I already reported about it, but when I build a drgeo
> image then do a small clean up like this:
> 
> === clean up ====
> FreeTypeFontProvider unload.
> ScriptLoader new cleanUpForProduction.
> StrikeFont cleanUp.
> 
> (MCPackage named: 'Announcements-Help') unload.
> (MCPackage named: 'FileSystem-Tests-Disk') unload.
> (MCPackage named: 'FileSystem-Tests-Memory') unload.
> (MCPackage named: 'FileSystem-Tests-Core') unload.
> (MCPackage named: 'FileSystem-Tests-AnsiStreams') unload.
> (MCPackage named: 'Metacello-Help') unload.
> (MCPackage named: 'Regex-Help') unload.
> RecentMessageList cleanUp.
> Smalltalk removeEmptyMessageCategories.
> Smalltalk garbageCollect
> ==== end of clean up ===
> 
> 
> Then, in the cleaned image, in any place where the progress morph is
> used, at the end of the progress process, a shaded morph (the background
> of the progress morph) remains on screen like a big smelling peace of
> shit - screenshot.
> 
> What cleaning I should not do?
> 
> Thanks
> 
> Hilaire
> 
> 
> -- 
> Dr. Geo -- http://www.drgeo.eu
> <progress-morph-background-like-a-smelling-peace-of-shit.jpg>





More information about the Pharo-dev mailing list