[Pharo-project] Method protocol nitpick
frank.shearar at gmail.com
Sat Jun 2 14:01:32 EDT 2012
On 2 June 2012 18:42, Sean P. DeNigris <sean at clipperadams.com> wrote:
> There are many test methods categorized as "testing". "Testing" means e.g.
> #isEmpty. "tests" (which is also used for test methods) would be better...
I usually put tests in a "testing - foo" category. Tests for #isEmpty
would thus be in "testing - testing". Kind've lame, but it does avoid
conflating behaviour and tests in the same category, while still
allowing categorising of tests.
(It's not universally true, but most categories are -ing words.
"instance creation", "initialize-release" are obvious counterexamples,
but otherwise we have "enumerating", "accessing", "testing", ...)
More information about the Pharo-dev