[Pharo-project] ContextPart >> copyTo: -> copyUpTo: ?
frank.shearar at gmail.com
Wed Jul 25 07:30:58 EDT 2012
On 25 July 2012 11:42, Mariano Martinez Peck <marianopeck at gmail.com> wrote:
> Guys. Did I miss something or ContextPart>>copyTo: should be renamed to
> #copyUpTo: ?
You feel that #copyTo: implies an inclusive bound? There's only one
#copyTo: implementor (ContextPart) and only one #copyUpTo:
(SequenceableCollection) and both are "up to and including" copies. In
other words there isn't a clear precedence one way or the other for
having #copyTo: meaning either "and including" or "not including".
Your argument is, I guess, that there should be? (The method comments
are perfectly clear on what both method do, at least.)
More information about the Pharo-dev