[Pharo-project] add temp does not add the temp in 1.3 13179

Lukas Renggli renggli at gmail.com
Tue May 3 14:38:48 EDT 2011


I can reproduce it everywhere, in Pharo 1.2 and 1.3. I don't think it
has anything to do with Shout or eCompletion. It looks like the
problem is that the new text editor that doesn't consequently reuse
the same Text object but instead creates new ones. The method
#compile:classified:withStamp:notifying:logSource: depends on the fact
that this is always the same Text instance, even after editing.
Luckily we can fix that easily, but there might be other subtle bugs
lingering around:

TClassAndTraitDescription>>compile: text classified: category
withStamp: changeStamp notifying: requestor logSource: logSource
	| methodAndNode |
	methodAndNode := self compile: text asString classified: category
notifying: requestor
			trailer: self defaultMethodTrailer ifFail: [^nil].
	logSource ifTrue: [
                " replace 'text' with 'methodAndNode node sourceText' "
		self logMethodSource: methodAndNode node sourceText
forMethodWithNode: methodAndNode
			inCategory: category withStamp: changeStamp notifying: requestor.
	].
	self addAndClassifySelector: methodAndNode selector withMethod: methodAndNode
		method inProtocol: category notifying: requestor.
	self instanceSide noteCompilationOf: methodAndNode selector meta:
self isClassSide.
	^ methodAndNode selector

On 3 May 2011 17:19, Stéphane Ducasse <stephane.ducasse at inria.fr> wrote:
> it does not work in OB in 1.3 nor in the plain default browser.
> Now in plain 1.3-core it is working in the default browser. So this is probably linked with a package loaded in the dev image. I was thinking OC?
>
> Stef
>
>
> On May 3, 2011, at 2:30 PM, Johan Brichau wrote:
>
>>
>> On 03 May 2011, at 10:14, Mariano Martinez Peck wrote:
>>
>>> aha.... I didn't try that ;)
>>> So...in 1.2.1 adding from a browser does work, but not from the debugger?
>>> And in 1.3 none of them?
>>
>>
>> I don't know about 1.3 but it's one of the things I started to notice about 1.2.1 this week.
>> In the browser, it works fine.
>
>
>



-- 
Lukas Renggli
www.lukas-renggli.ch




More information about the Pharo-dev mailing list